Automatic back-ups with Snapshot won't run

Hi

The title is quite self-explanatory, however I'll try to elaborate.

When I try to active the scheduled back-ups on my domain, I have zero luck getting it to work.

The Max Execution Time for php is 120 sec. When I try to edit this in htaccess ("php_value max_execution_time 300") the website will return an Error 500.

Is the lack of back-ups due to the Max Execution Time? If yes, how do you suggest I change it?

Best regards,
Christian.

EDIT: Thought I might add this: When I try to run a manual back-up to the WPMUDEV Cloud I get this error message: "GATEWAY TIMEOUT. The gateway did not receive a timely response from the upstream server or application."

  • Kris Tomczyk

    Hi Christian

    Hope you are doing good today.

    I am sorry to hear that you have met this problem.

    You can follow this article here https://premium.wpmudev.org/blog/increase-memory-limit/ which presents other option to increase/change values like max_execution_time.

    Minimum max_execution_time value for Snapshot is 180 but recommended is 300 or higher for larger sites.

    If .htaccess option returning an error 500 it is possible that code is added in incorrect place.
    Also in many cases servers requires to close this define in additional tags (IfModule):

    <IfModule mod_php5.c>
    php_value max_execution_time 300
    </IfModule>

    where mod_php5.c you need to adjust to your php version you use for this domain.

    In above article you will find option to increase this value via php.ini file which needs to to place in /wp-admin/ folder and have this line added:
    max_execution_time = 300

    As for the error message:
    GATEWAY TIMEOUT. The gateway did not receive a timely response from the upstream server or application. it is also related to max_execution_time value.

    I also recommend to check you memory_limit value and just in case set it up to 512M.

    To check if those values are implemented correct for you site, please create a file called info.php on root of your site and add to this file this line:

    <?php phpinfo(); ?>

    then in browser type http://yourdomain.com/info.php (where yourdomain is your domainname), check max_execution_time and memory_limit values. If they are not change you will need to contact with your host provider to increase those values.

    Kind Regards,
    Kris

  • Christian

    Hi everyone reading this

    Just following up. It's been a few Fridays since I said I would test out the solutions. And I have now. Unfortunately, none of it worked for me. I kept getting error messages about this and that.

    I contact the host's support line but it helped me none, too.

    Instead, I went on a clean-up through FTP and removed a staggering 13 GB (!!) of files that wasn't needed - locally hosted back-ups, too. I've just run 2 snapshots and it was hella quick and easy. The auto-back-up should be working now and it uploads to a SFTP-server I've setup and AFAIK the WPMUDEV Cloud, too.

    Anyways, it was quite a rookie mistake to have that many useless files on the server, but it's been fixed now.

    Best regards,
    Christian.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.