Automatic daily backups transfered to my own server

Hi there,

I want to transfer the snapshots i make of my website automatically to my FTP server, i've tested the connection and it worked so i added it to destinations. When i select the right destination and make a snapshot all goes well and it says succes, but when i look on my server the snapshot is nowhere to be found.
Do you have any solutions for this?

Thanks in advance,

  • Dimitris

    Hey there Roy Janssen,

    hope you're doing good and thanks for reaching us! :slight_smile:

    Could you please grant us with support access to your website to inspect the log file of the snapshot?

    You can do so via our "WPMUDEV Dashboard" plugin, no need to share credentials. More details on this can be found here https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Also, please inform us in which snapshot this is happening in case you have multiple snapshots. :slight_smile:

    Warm regards,
    Dimitris

  • Dimitris

    Hey there Roy Janssen,

    hope you're doing good today and I'm sorry for the late reply here.

    I just accessed your website and inspected the log of "Backup test" snapshot but I wasn't able to extract any valuable information from there.

    I'd like you to make couple of changes and then activate the WP debug to continue testing.
    1. Raise max_execution_time limit from 45 to a higher value, like 300.

    For that you may use the instructions from the original documentation here
    http://codex.wordpress.org/Common_WordPress_Errors#Maximum_execution_time_exceeded
    or contact your hosting provider (they should be able to do so for you in no time).

    2. Insert the following line in wp-config.php file, just before the /* That's all, stop editing! Happy blogging. */ comment line:
    define( 'WP_MEMORY_LIMIT', '256M' );
    Reference: https://codex.wordpress.org/Editing_wp-config.php

    3. Enable WP_DEBUG and process your snapshot one more time.
    Again in wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to replicate the error. By doing so, a /wp-content/debug.log file should be created. Simply download it, rename it to debug.txt and attach it here in your next reply if this continues.

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello Roy!

    That's a good finding!

    I checked your site and noticed that all your snapshots were created manually and currently set to "save only". I have then run one of them (the first one on top of the list) and the file was not pushed to the destination: it got stuck in "pending" state and the log only confirmed that the local archive was created.

    I then set this snapshot to be run each 5 minutes and found out that this doesn't work either. Furthermore, the last "Next run" date (above the snapshots list) is way in the past. This suggested that there's an issue with WP Cron (it's an internal WP tool used to automatically run tasks over given period).

    Check with a WP Crontrol plugin (I installed and enabled it but please feel free to disable and remove it anytime) revealed that while all the cron tasks are set properly, events are not triggered as expected. This is the error that's returned instead, you can see it on "Tools -> Cron Events" page in your site's dashboard:

    There was a problem spawning a call to the WP-Cron system on your site. This means WP-Cron events on your site may not work. The problem was:
    cURL error 35: error:14077438:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert internal error

    This seems to be a case of an old bug in Linux related to OpenSSL libraries. Take a look here

    https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/861137

    and here please

    https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/1475228

    This is something that you host should be able to fix. Please get in touch with them and let them know about that error and ask them if they could take care of this. I can see some solutions that involve changes on server level but I suppose this may be as simple (for the host) as getting OpenSSL and all the cURL SSL certs up to date and probably reconfiguring OpenSSL. If it's not a dedicated server/VPS but a shared hosting, this may also be affecting other customer of their service so I believe they should deal with that fast.

    Let me know please what they said!

    Best regards,
    Adam

  • Roy Janssen

    Adam,

    I have checked and the OpenSSL version and it is the latest release 1.0.2j-48. The thread links which you provided are out of date and this leads us to think that the plugin is trying to connect over HTTPS with SSLv2/v3 ciphers which are obsolete and dangerous. Therefore my advice is to contact the developer of the plugin for further assistance on updating the connection ciphers or run the backups over HTTP, not over HTTPS.

    However if the plugin is not using obsolete ciphers then we need more information on how to recreate the issue on our end and any login details which might be required so we could further investigate.

    Looking forward to hear from you.

    Best Regards,

    Nikolay Arabadzhiev
    Senior Technical Support

  • Adam Czajczyk

    Hello Roy!

    Thank you for letting me know about that.

    If and only if OpenSSL and cURL certs are indeed up to date (and properly configured), these threads would indeed be outdated. I did linked to them though because the error suggest otherwise. Let's however assume that it's all all right on a server's side just like Nikolay says.

    This would mean that there's something else interfering here and causing the error that's misleading. That happens sometimes. I did not came across that issue in relation to Snapshot ever before and I'm still not sure whether it's related to the plugin only or to the entire install - it seems that WP Cron is affected and Snapshot is only using WP Cron which is internal part of WordPress.

    Let's then try to dig a bit deeper.

    Did you notice any other "periodic tasks" (if there are any) that are not completed on your site? Did the Snapshot work fine before and only started to "break" just recently or wasn't it working from the start? Were there any changes (including new themes/plugins installs and/or any kind of updates) made to the site recently?

    Let me know please.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.