Automatic Links questions

Hey Y'all,

1. When using custom keywords in Infinite SEO, how do I set it so that a keyword I choose does not link within the main page I am having that word link to? For instance, I have this set up:
cacao, http://www.integral-health-guide.com/raw-cacao-beans/ and I do not want the word cacao to be linked on that page but instead only from other pages that have that keyword. Any idea how to do that?

2. Also, I have the keyword 'organic' set, but for some reason the phrase 'advantages of organic farming' is getting a link on it and I do not want that.

Thanks for the input.

  • Mason

    Hiay rawearthman,

    Many thanks for joining us at WPMU DEV! Your site's looking great :slight_smile:

    how do I set it so that a keyword I choose does not link within the main page I am having that word link to? For instance, I have this set up:
    cacao, http://www.integral-health-guide.com/raw-cacao-beans/ and I do not want the word cacao to be linked on that page but instead only from other pages that have that keyword. Any idea how to do that?

    You can customize the keywords on individual pages is that not what you're looking for? There should be an Infinite SEO settings are on each page.

    2. Also, I have the keyword 'organic' set, but for some reason the phrase 'advantages of organic farming' is getting a link on it and I do not want that.

    I'm assuming you mean the word organic when on the Advantages of Organic Farming page: http://www.integral-health-guide.com/advantages-of-organic-farming/

    Is that correct? We don't have any checks setup to see if you're on the page that the auto-link feature is using. We could look at something like this in the future, that is, assuming I've got it right.

    Can you confirm the above and we'll continue to look at this?

  • rawearthman

    Hi Mason,

    Not sure. So how do I customize a keyword on a main page to not link back to the same page? For instance, on the cacao page at http://www.integral-health-guide.com/raw-cacao-beans/ the word cacao links back to the same page. I want other pages with the word cacao to link to this page but not that main page. And you are saying there is an infinite seo setting on each page to set this? I see for the meta title, description, and meta tags, but nothing for automatic linking on that page. Am I missing something?

    As for the next question, yes at http://www.integral-health-guide.com/advantages-of-organic-farming/ As you can see down below the phrase advantages of organic farming links to the same page. Strangely I do not have that phrase set in automatic linking, so I am just wondering why it is showing up.

    Thanks again.

  • Mason

    HIya @rawearthman,

    I want other pages with the word cacao to link to this page but not that main page.

    I understand. That's what I was referring to when I said we don't have any checks within the SEO plugin right now to check for that. I'm sure we could add this capability and we can consider this a feature request.

    And you are saying there is an infinite seo setting on each page to set this? I see for the meta title, description, and meta tags, but nothing for automatic linking on that page. Am I missing something?

    Nope. All I was referring to was exactly the elements you're seeing - there's no page-by-page element for auto-links.

    down below the phrase advantages of organic farming links to the same page. Strangely I do not have that phrase set in automatic linking, so I am just wondering why it is showing up.

    That's really bizarre. Have you checked to make sure that it is not coded as a link within that post/page? I can't think of what would cause an auto-link. Did you previously have this phrase as an auto-link? Are you running any caching plugins on your site currentliy?

  • Arun Basil Lal

    Hello rawearthman,

    Haven't heard from you in a while. Hope everything is good.

    Just wanted to point out on how Automated Linking in Infinite SEO works. If I assume it right, you will have the settings on your "Step 5, Automated Links" as:

    Insert links in -> Posts = Ticked
    Link to -> Posts = Ticked (and others maybe)

    The plugin picks up post titles and links to them automatically if the above settings are on. This means that every instance of "Advantages of Organic Farming and Authentic Foods" which is the post title in this case, will be linked to the page, http://www.integral-health-guide.com/advantages-of-organic-farming/

    (Read about it here: https://premium.wpmudev.org/forums/topic/infinite-seo-keywords?replies=4#post-203635 ) (and we take up full responsibility here, the documentation needs to have this, I will update it right away, actually Thanks for bringing this up)

    So here are the fixes:

    For instance, I have this set up:
    cacao, http://www.integral-health-guide.com/raw-cacao-beans/ and I do not want the word cacao to be linked on that page but instead only from other pages that have that keyword. Any idea how to do that?

    As Mason said, this not a feature right now, but there is a work around.

    Find the Page ID first. Am not sure if it's a page or a post, but here is how you find the ID. Go to your WordPress Admin > Posts / Pages > Hover over the link and check your status or click open it. The number in the URL is the ID

    See the screenshot attached. Forgive the crude text :wink:

    Now go to Automated Links Settings and you have a section :Ignore posts and pages". Give the Post ID there. Again See the screenshot attached.

    As for the next question, yes at http://www.integral-health-guide.com/advantages-of-organic-farming/ As you can see down below the phrase advantages of organic farming links to the same page. Strangely I do not have that phrase set in automatic linking, so I am just wondering why it is showing up.

    I hope my explanation at the start of this post makes it clear why this is happening. Now here is how to fix this. Three suggestions:

    - Either change "Advantages of Organic Farming and Authentic Foods" in the post to something slightly different from the Post Title, say "Advantages of Organic Farming and Having Authentic Foods". Now the Post Title is different from the phrase and it won't be linked.

    - Include the Phrase "Further Advantages of Organic Farming and Authentic Foods" in a heading Tag, H3 or H4. Now in the Automated Link settings, tick "Prevent linking in heading tags " in the "Exclude Headings" section. See the screenshot attached again, the second one.

    - In the plugin settings for Automated Links, tick "Case sensitive matching". Now make your title into a different case, at least a word of it. Say "Further Advantages of Organic Farming and Authentic foods" and it shouldn't be linked.

    I hope that clears all the questions you had. Let me know if you have more of them.

    One more thing. Your site looks amazing! Both design wise and content wise :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.