Automatic update failed – any special requirements

Hi! I registered for trial and tested with my companies website, turned on automatic updates and when it ran for the first time the site went down with a 500 internal server error. I had to restore the site from our backup.

I found out later that the theme (the 7 from https://the7.io/ ) was updated but not plugins that belongs to the theme and that caused an server error. When I manually updated the plugins for the theme and then updated the theme all works fine.

Are you aware of this? Is there any special requirements where automatic updates doesn't work ( like the 7 theme ) ?

  • Dimitris
    • Support Star

    Hello there Web-IT Solutions

    As long as updates are using the native WP way and are visible in /wp-admin/update-core.php in your website, then Hub and Automate should be able to proceed with these updates.

    If these plugins aren’t getting updates by their own repositories though, they are part of the theme update and they can only be updated via another page of the theme options, then Automate or Hub can’t update them.

    Having said that and as I’m not too experienced with how the 7 theme is providing updates, could you please let me know which plugins are included and if you’re getting update notifications about them in the generic update page of the WordPress admin?

    Please advise!

    Warm regards,

    Dimitris

  • Web-IT Solutions
    • New Recruit

    Ok, then I understand.

    I think it was the plugin “The 7 Elements” that failed with automate. I do remember that it was visible on the plugin page that an update was needed. When I updated manually it was updated on another page, not the WP plugin page.

    But I think we will look into another solution for our hosted sites since Automate may or may not work depending on the theme and plugins.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.