Automatic update unable to update core

We have several instances where the automated update cannot update WordPress core, such as greatamericansbarber.com this morning.

Is there a reason for this, or something I should change?

I granted access in the WPMU DEV plugin for support to access the site if needed.

Thanks for the help!

  • Adam Czajczyk
    • Support Gorilla

    Hello Allan McNabb

    I hope you're well today and thank you for your question!

    I see this message in Automate logs, regarding core update on the site assigned to this ticket:

    Update WordPress core error: unexpected_response - We got an unexpected response from your website: "500 Internal Server Error"

    This usually means that either some process on site caused the site to temporarily go down and/or resource limits being used. However, there are two things that I'd like you to check before we go further with troubleshooting:

    1. As splaquet already suggested (thanks!) check the "wp-config.php" file against following lines:

    define( 'AUTOMATIC_UPDATER_DISABLED', true );

    define( 'WP_AUTO_UPDATE_CORE', false );

    2. Check on your server (you might need to consult that with your host) if you can increase the PHP "max_input_time" option value. It's currently set to 45 which is quite a low value and might result in such issues. I'd recommend settings that to something over 100 - preferably around 160-180 if possible.

    3. Check with your host (if possible) if they could check server logs to see if there's been any requests from these IPs that were/are blocked on the server; if so, if they could white-list the IPs there:

    66.135.60.59
    66.135.49.214
    66.135.60.64
    104.236.238.22
    104.236.50.140
    34.196.51.17
    52.57.5.20,

    Let me know about results please and if none of that is the case/helps, we'll then investigate it further.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.