Automessage PHP Errors

Hello,
Thanks in advance for your help. I recently switched from BlueHost to WP Engine. The AutoMessage plugin was working great with BH but not so much for me at WP Engine.

Here's an example of the error messages I'm receiving:

[client 24.27.67.0:19729] PHP Fatal error: Uncaught exception 'phpmailerException' with message 'Invalid address: noreply@https://community.citizensclimatelobby.org' in /nas/content/live/cclcommunity/wp-includes/class-phpmailer.php:946\nStack trace:\n#0 /nas/content/live/cclcommunity/wp-includes/pluggable.php(352): PHPMailer->setFrom('noreply@https:disappointed:...', 'CCL Community', false)\n#1 /nas/content/live/cclcommunity/wp-content/plugins/automessage/classes/class.user.php(103): wp_mail('maanasa.koduru@...', 'Connect with yo...', 'Howdy saikoduru...', 'From: "CCL Comm...')\n#2 /nas/content/live/cclcommunity/wp-content/plugins/automessage/classes/class.automessage.php(1599): Auto_User->send_message('Connect with yo...', 'Howdy %username...')\n#3 /nas/content/live/cclcommunity/wp-content/plugins/automessage/classes/class.automessage.php(411): automessage->force_process_user('3111')\n#4 /nas/content/live/cclcommunity/wp-content/plugins/automessage/classes/class.automessage.php(325): automessage->process_admin_updates()\n#5 [internal function]: automessage->add_admin_h in /nas/content/live/cclcommunity/wp-includes/class-phpmailer.php on line 946

Not sure why the email address is showing noreply@https://domainname instead of noreply@domainname and the automessage errors.

Thanks for taking a look at this for me.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Richard,
    Hope you are doing good today!

    I juste tested it on my test site hosted on WPEngine and its working just fine for me without any errors/warnings.

    It could be due to migration process. Please delete this plugin and then install fresh copy of the plugin from our website via WPMU DEV Dashboard plugin.

    If you are still getting this error then please provide steps so I could replicate it on my own test site and report this behaviour to our developer.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid

  • Richard
    • Flash Drive

    Hey Sajid,
    I tried that, but no still bueno.

    Steps: When plugin is active the above error messages occurs. No additional steps. It happens continuously...to the point where the cron job doesn't stop and my hosting coming has to kill the process and restart services and I get 502 errors.

  • Sajid
    • DEV MAN’s Sidekick

    Hi Richard,
    Hope you are doing good today!

    I can see that you have plenty of plugins installed on your website with a custom BuddyPress theme. That could be a plugin/theme conflict.

    Please make a plugin/theme conflict test as described in our getting support manual (flowchart) and then check again. I avoid to do this on your live site without having FTP access and your permission.

    Best Regards,
    Sajid

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.