Automessage won't send immediately

Hi,

I've set up automessage and it sends messages -- but it won't do it automatically or immediately.

I have a new registration email that's set to send immediately. The process is not paused. When users register, the messages just pile up in the queue and I have to click "process" to get them to send.

I'm running wp 3.5.1 and using the latest version of automessage.

K

  • aristath

    Hello kalanga, I hope you're well today.

    but it won't do it automatically or immediately.

    I would like some more info just to be able to support you better on this one.

    Could you please send me the url of your site?
    What host are you using?
    Do you have any caching plugins enabled? If so, try disabling them and empty your caches.

    Do you have access to your server's error logs? If so, can you find anything in there relative to emails and the automessage plugin?

    Just from reading your issue, it looks to me like your WordPress installation doesn't run cron on time or there's an aggressive caching plugin in operation, or a reverse proxy. In any case, all of these can be fixed provided we know exactly the environment of your site.

    Please advise,
    Aristeides.

  • aristath

    I 've never worked with Amazon before (or Varnish for that matter) but from what I understand, If varnish is serving a non expired cached page then your visitor is not hitting WordPress. Instead tey see a cached version of your site.

    A good step forward would be to set varnish to purge the caches sooner, so that cron runs fore frequently and emails will probably get through then.

    It still won't be "instant", but it will be a lot better.

    Cheers,
    Aristeides.

  • Barry

    The mystery is why they're getting queued up and why triggering cron (which wasn't cached) doesn't get them to process. Can I create a separate cron job that gets auto message to process the queue?

    Automessage doesn't use wp-cron for processing (yet) - the move over is on the roadmap for the next version. Instead, it hooks into a pageload. If you have caching enabled and it is not hitting the WP to load a page then the process to send messages will never be processed - however, they should be being processed when people are in the admin area (assuming you are not caching that :slight_smile: ) - with that in mind, if you have access to your php debug log, it might be worth outputting some debug messages to the error log to see what is happening.

    If there is a way to remove a particular page from being cached, then you could set up a server cron job to hit that page on a semi regular basis to ensure that processing is reliable.