availability clash with google calendar and services

Hi,

when we try to implement the plugin, some time-slots are still showing available, when they shouldn’t.

for example an appointment is already booked at 3pm, so a 120 min session from 2pm shouldn’t be possible, but a 45 min session with a 15 minute post buffer should be available…

what’s the best way for you to have a look or let us know how we can go about this?

cheers

  • Patrick
    • Support Monkey

    Hi there @kate

    Welcome to WPMU DEV, glad to have you aboard!

    The easiest & quickest way would be for you to enable support access via your WPMU DEV Dashboard. That way, we can pop into your admin and have a first-hand look at how you have set things up.

    It’s likely just a tweak to a few settings here & there, mainly to do with the Durations & Paddings addons I believe you have activated.

    If you’re not sure how to grant support access, you’ll find simple instructions right here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I hope this helps! And thanks for being a member :slight_smile:

  • George
    • Accounts - Team Leader

    Hey there @kate,

    Really sorry for the extreme delay on this one!

    I’ve quickly checked your settings and modify them to suit your needs. Could you please check that out and let us know if that works for you?

    Looking forward to your reply :slight_smile:

  • Kate
    • WPMU DEV Initiate

    Hi,

    I’ve checked, but just he 45minute session seems to respond to the availability of the google calendar. Any other slots, still don’t respect the calendar availability…

    any other thoughts?

    kind regards

  • Kate
    • WPMU DEV Initiate

    have double checked…It’s not synching correctly with my Google calendar. Any session over 45min isn’t taking into account the other appt. already booked in. Say, for instance tomorrow. I don’t have a free space until 2:45pm. The app, when I select 60min is saying I have spaces all day. Not good. If I select a 45min session tomorrow it shows correctly that I’m not available until 2:45pm.

    have granted access again for the support

  • Kate
    • WPMU DEV Initiate

    hi,

    if this is not resolved by the end of next week, we will be requesting a refund as it has now been 2 weeks of mostly waiting without any progress. i will extend the access again as it has now been closed again…

  • Vaughan
    • Support/SLS MockingJay

    Hi Kate,

    Can you confirm, are you using your default primary Google calendar, or did you create a new calendar just for apps+? It doesn’t work with the primary calendar as syncing to primary calendar has issues (that’s a google requirement and not an actual issue with the plugin)

    I’m just asking because the email address you’re using in your GCal settings is your primary email address, whereas it should look something like > abcdefg1234567890@group.calendar.google.com

    Thanks

  • Kate
    • WPMU DEV Initiate

    we didn’t know that it cannot be the primary…your website just said “works with google calendar.” but So, we’ve tried creating a new calendar (appointments) and duplicated over all the events and resynchronized. it is still not fully recognizing the events and respecting the times..

  • DavidM
    • DEV MAN’s Mascot

    Hi Kate,

    Thanks for your reply and for your patience here! Sorry if there was any confusion with the primary calendar usage, the plugin does make a note in the settings:

    Create a new Calendar by selecting “my Calendars > Create new calendar” on left side pane. Try NOT to use your primary calendar. If you have to, please see this post: Forum link

    It’s not that it couldn’t be used, there are just particular cases where it can be problematic.

    I’m glad that seems to mostly be working for you now though, could you just let us know more about it not fully recognizing the events and times?

    I’ll also chat with you more via the email you sent. Really looking forward to ensuring this is sorted for you!

    Thanks,

    David

  • Kate
    • WPMU DEV Initiate

    We created a new calendar called appointments and are trying again – so it’s not a primary calendar. The app just seems to take notice of 45minutes sessions – the first option in the drop down, but if you choose any other duration, the app doesn’t respect the calendar appointments so they’ll be a clash of schedules. somehow the 45 minute one sometimes seem to respect the appointments in the google calendar, but all other durations, 60, 75, 90 120, do not work.

  • Tyler Postle
    • CGO

    Hey Kate,

    Sorry to ask again, but could you re-grant support access?

    I’m wondering if you have more than 1 service provider on the apps that are above 45 minutes, is that right?

    If so, lets say you have a service with 2 providers. Then you book a gcal app – that takes up 1 spot. Both providers will still be available until that 2nd spot is booked, then no more providers will be available.

    Not sure if that is the case here but just wanted to mention it. If you’re still having an issue I’ll take a closer look :slight_smile:

    Talk to you soon!

    Cheers,

    Tyler

  • Kate
    • WPMU DEV Initiate

    Have set up access for you.

    Still the same issue. There is only one service provider and will always be only one. Even before trying to book, when there shouldn’t be any slots open, there are open slots…

  • Tyler Postle
    • CGO

    Hey Kate, very sorry for the delay here. Staying on top of this so we can get it sorted asap.

    I just checked your schedule and it looks to be showing properly, but I’m thinking that’s because you don’t have any gcal spots reserved right now? Can you reserve one so I can see the issue, or give me an example of a time that should be available that isn’t right now. Then I can look further into this.

    I’ll keep an eye out for your reply. Talk to you soon Kate!

    Cheers,

    Tyler

  • Kate
    • WPMU DEV Initiate

    It’s definitely not working..

    Take today for instance. The online calendar says I can’t do a 45min booking @ 12, I can. It also say I can do a 2pm appt, I can’t. Looking at next Thurs 9/4/15, I blocked the whole day out as I’m on a course. It is still letting people book at 5, 6 & 7pm. Oh, just changed to a 60min session on the 9th and it says the whole day is free!

  • Tyler Postle
    • CGO

    Hey Kate, good to hear back and thanks for the clarification of which days should be showing, that will help a lot with troubleshooting :slight_smile:

    Sorry to ask again, access has expired. can you re-grant support access? Then I can take a close look at what is going on here.

    Talk to you soon!

    Cheers,

    Tyler

  • Tyler Postle
    • CGO

    Hey Kate,

    Hope you're having a good weekend!

    I've been looking at this and the reason you still have the 5, 6, and 7pm slots open on April 9th is because it looks like the Gcal event ends at 4:30pm. It goes 8:30am – 4:30pm. As seen in my screenshot.

    Is you gcal on the same time zone at your WP site? Your WP site is UTC +0. You can find and change that via:

    Settings > General. Make sure it matches your gcal calendar :slight_smile:

    Also, if you're booking off a full day it might be easier to just use the built in "exceptions" feature in Apps+, you can find this via:

    Appointments+ > Settings > Exceptions tab.

    Then select the day you want off in the exceptional non-working days. Select it for both the "No specific service provider" and your own "Kate" service provider.

    So it looks like the time zone is the issue here with your gcal, if that isn't the case just let us know and we can have another look :slight_smile:

    Look forward to hearing back!

    Cheers,

    Tyler

    PS. You can adjust the gcal timezone if you go to it and "edit calendar settings".

  • Tyler Postle
    • CGO

    Hey Kate,

    Hope you had a great Holiday weekend!

    Support access has expired again, would you mind sending in admin access to me through our private contact form? Might be easier that. It assigns it directly to me :slight_smile: or you can re-grant access.

    If you choose to send in admin access, then use this form: https://premium.wpmudev.org/contact/

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me :slight_smile:

    Send in:

    Subject: “Attn: Tyler Postle

    -WordPress admin username

    -WordPress admin password

    -login url

    -link back to this thread for reference

    -any other relevant urls

    https://premium.wpmudev.org/contact/

    Then I can see why it isn’t showing on those days. Looks like I missed the Tues example, but I will still be able to see Wed and thurs :slight_smile:

    Cheers,

    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.