Avatar doesnt show up

Hi All,

This is a bit embarrassing.
Avatars installation :...done
Upload :.....done
Crop :....Done
It said "Avatars has been updated (or something like that) "
But,....... Nothing has changed.
No Avatar....at all.

Hmmm,... i read some of the similar problem in the forum, try some, but still nothing change.
Hopefully, someone can help me with straight forward solution.

Thanks Guys
Arda

  • DavidM

    Hi Arda,

    Hmm, this could have to do with the your site's configuration. Could you let us know what version of WordPress your site is on? And you do have Multisite enabled, correct?

    Also, are you using BuddyPress on this site by any chance? The Avatars plugin isn't compatible with BuddyPress, but you really wouldn't need it if you're using BuddyPress as avatars are already handled by BuddyPress itself.

    -David

  • arda

    Hi David,

    THank you for your reply.
    Wordpress that I use is version 3.2.1. updated.
    Multisite Enable.
    NO Buddypress....

    What I've been realize is that, when the page is still loading, there is a box (looks like avatars box) next to my Login widget. I activated WPMS Sidebar Login Widget.
    But when the page is finished to upload, the box has gone, nothing there.

    I tried in my other website, and it also come with the same thing.

    Plugin within my website (ikreatif) has also has BBPress Avatars activated, but not through out the network. Is this something to do with my problem?
    They come as a package, right?
    cos when I tried to delete one of them, it showed me both need to be deleted, so i canceled it.

    What happened actually is that, when I try to upload an image as avatar, the upload process until cropping the image was successful, but then when it finished to cropping and it was said that the avatar is being updated, nothing there. I tried to upload another, then come "There was an error uploading the file, please try again."
    I tried "Alternative Upload", its the same.

    Hmmm......confused:slight_smile:

  • arda

    Hi cfai,

    Sorry to say man, I dont have a clue.
    I tried to look for some solutions in the forum, couldnt get one either.

    THe best I can try is" try to reset everything from zero."
    THis I do cos Im still in a trial of everything in WP. Nothing to lose,but time...yet.:wink:
    Also got a clue from an article in the web (I really really forgot to save the link), but they got something to do with automatic install of Wordpress Multisite from Cpanel using softaculus,fantastico or similar to those two.
    and my hosting provider said something different, it because of I'm using a shared hosting,eventhough I paid for it. (for this one, I think my webhosting a bit confuse of how my exact problem is.)
    This problem is getting worst cos even more problems showing up with my uploads media for my sub-sites.
    and also I've tried using Buddypress, they also having similar problem for member who trying to upload pictures for their album....nothing show up. (Please check my tread about Buddypress Album)
    I guess other than media upload, everything else works just fine.

    So, just to share my friend. its up to you then....

    Thanks
    Arda

  • pbrink

    Same problem here.

    Avatar uploaded OKE
    Croped OKE
    Avatars has been updated (or something like that) "

    But showing a broken the image.
    /avatar/user-1-96.png?rand=dc06615ccb0507433b86ceeb0589a71c

    The /avatar/ folder is redirected within the .htaccess to the following file:
    wp-content/avatar.php?file=$2

    Now I insert the URL of the image into the browser (/avatar/user-1-96.png).
    The browser returns the following error:
    Warning: require_once(mu-plugins/avatars.php): failed to open stream: No such file or directory in public_site/wp-content/avatar.php on line 56

    This is the location were the old plugin was installed...? Any clue how to fix this, do I need to replace the avatar.php with the the default one from a clean WP install?

    Thanks in advance,
    Pieter

  • pbrink

    Hi Guys,

    After downloaden a clean wordpress install I saw that there is no /wp-content/avatar.php.

    So I search the forum for ".htaccess avatar" and found the following post:
    https://premium.wpmudev.org/forums/topic/avatars-be-careful-about-upgrading-to-the-35-version#post-65459

    Removing the rewriting line from the .htaccess is the solution to my problem. I think that this should be noted with the installation / upgrade instructions.

    Thanks,
    Pieter

  • Timothy Bowers

    Hey there! :slight_smile:

    Just checking in to see how things are going with this one and if you need any further help. :slight_smile:

    We haven't heard from you on this thread for a while. So I'm going to presume your all fixed up now and don't need any further assistance.

    However if you have more questions or need some more help then please feel free to respond in this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.