[Avatar Plugin] Avatars

Hi,
Not able to remove this from my network or delete plugin . Not via WPMU DEV Dashboard and not in admin. Gives an Internal Server Error (..?)

Please, advise.

Eric

  • Adam Czajczyk
    • Support Gorilla

    Hello Eric

    I hope you're well today and thank you for your question!

    Does it give "500 Internal Server Error"? That's a bit surprising if it happens upon plugin deletion but still - it would suggest that there's most likely some issues with resources. In many cases it's related simply to the WP memory limit. You can check it by going to the "Network Admin -> WPMU DEV -> Support" page and clicking on "System Info" button there.

    Once you are there, select PHP tab and look for the value of "memory_limit". That should probably be 256M or 512M or similar. You might want to note that value down. Then go to the "WordPress" tab on the same page and scroll it all the way down until the "WP_MEMORY_LIMIT" line. See if the value there is same or similar to the one that you noted down or if it's showing anything less than 128M.

    If it's less than this, you can try increasing it by adding following line to the "wp-config.php" file of your site, right above the "/* That's all, stop editing */" line:

    define('WP_MEMORY_LIMIT', '256M');

    That should suffice in most cases so try removing the plugin again after that. If that doesn't help or you just don't want to deal with editing "wp-config.php" file you might as well simply delete the plugin from the site via FTP or cPanel "File Manager".

    To do this, you'd want to access the site install using FTP (or cPanel "File Manager" module) and go to the "/wp-content/plugins" folder of your site; you should see "avatars" folder there so you can simply remove it (though I'd strongly recommend making sure that there's either a full backup of the site available or that you have downloaded that folder to your local drive first, just to be able to restore it in case anything went wrong - even though it shouldn't).

    Best regards,
    Adam

  • Eric
    • New Recruit

    Hello Adam,

    It gives and Internal Server Error (No 500). I've increased the memory limit, deleted the plugin, re-installed the plugin, activated the plugin.

    When trying to remove it from the network, it gives again the same error. I will delete it again and won't use it, until this problem is solved. I've a fresh WP-installation, so there is probably something else not working ...
    Regards,

    Eric

  • Adam Czajczyk
    • Support Gorilla

    Hello Eric

    Thank you for letting me know about it.

    It's a bit strange that the plugin "says it's de-activated" but it's actually not. This together with those 500 errors mean that something's not quite right either with the WP install/configuration or with the server or both. I would like to take a closer look at this.

    Could you please enable support access for me so I could do this? To enable it, please go to the "Network Admin -> WPMU DEV -> Support" page in your site's back-end and then click on "Grant support access" button there.

    Let me know here once it's done and I'll check the site against the issue.

    Kind regards,
    Adam

  • Predrag Dubajic
    • Support

    Hi Eric,

    It seems that the support access is still not granted on your site, can you please try granting it again and let us know here so we can give it another try?

    In the meantime, I have tested both Avatars and Smush Pro on two of my multisites, subfolder and subdomain, and neither of them had issues with deactivating or removing the plugin.
    So it seems that this is something specific to your network and we would like to chat what might be causing this for you.

    Best regards,
    Predrag

  • Eric
    • New Recruit

    Hi Predag,

    As mentioned before, I granted support. Yesterday, I wanted to check if there was an answer from support, but there wasn't. I also noticed that my website was'nt synced anymore. Strange, because, I haven't touched anything ...
    Anyway, I will grant support again immediately and I'll hope you're be able to give me support on this asap. Thanks! Eric

  • Predrag Dubajic
    • Support

    Hi Eric,

    It seems that your site is not connected with your account again so support access won't work either.
    I had a look at your account and it shows that the site was disconnected just 30 seconds after you have logged in.

    So it seems that something strange is going on with your installation and it could be what's preventing disabling of the plugins.

    Could you provide us with cPanel or FTP login details so we can have a closer look at your setup?
    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:
    NOTE: Don't change selected topic in the dropdown, just leave it at "I have a different question".

    Subject: "Attn: Predrag Dubajic"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.