Avatars, all other plugins not working

I'm sure I'm missing something simple, but after hours of search, I can't find what it is. I've had Avatars, Recent Global Posts, and other plugins working great.

I recently upgraded my site to 3.0.1, installed the new version of Avatars (carefully following, checking, and triple-checking the directions), but nothing appears in the users menu to upload an avatar. Tried installing Recent Global Posts, and that also does not appear in the Widgets (I'm assuming because Avatars isn't working). I do not have buddypress installed.

No php errors are showing in the error logs. Site is http://werunforgood.com. htaccess is as follows

RewriteEngine On
RewriteBase /
#uploaded files
RewriteRule ^(.*/)?files/$ index.php [L]
RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]
RewriteRule ^(.*/)?avatar/(.*) wp-content/avatar.php?file=$2 [L]
# add a trailing slash to /wp-admin
RewriteCond %{REQUEST_URI} ^.*/wp-admin$
RewriteRule ^(.+)$ $1/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]
<IfModule mod_security.c>
<Files async-upload.php>
SecFilterEngine Off
SecFilterScanPOST Off
</Files>
</IfModule>

Not sure where to look anymore! Thanks for any help you can give...

  • Mason
    • DEV MAN’s Sidekick

    Hiya!

    Well, your htaccess file looks correct to me.

    Are you saying none of the plugins are working or just the two mentioned specifically above?

    Tried installing Recent Global Posts, and that also does not appear in the Widgets (I'm assuming because Avatars isn't working).

    Recent Global Posts works fine independently of the Avatar plugin (just doesn't show avatars of course). If you're not seeing the widget then something is not installed correctly.

    I know you've already spent quite a bit of time going through this, but can we verify that you've done all the steps as listed here:
    https://premium.wpmudev.org/project/recent-global-posts-widget/installation/

    Thanks. We'll help ya get it sorted!

  • deefisher
    • WPMU DEV Initiate

    Thanks for responding masonjames!

    I did go through the steps again, downloading and re-installing just in case the file was somehow corrupt. Same thing, it's not appearing in the widgets list.

    Nothing showing in the error logs either. Argh!

    I do have Akismet and Dailymile plugins installed (non-mu) and they are working fine. Come to think of it, none of the mu plugins are working (I also have login-image, which worked before the upgrade).

    Just for kicks, I just uploaded the new version of wpmu-nelo to see if it might be something with the template. Again, no luck.

  • Mason
    • DEV MAN’s Sidekick

    If no mu-plugins are showing up then it would seem to me there's something wrong with the setup here.

    Can we just verify that the plugins are directly inside of mu-plugins and not in a subfolder.
    For example, should be:
    mu-plugins>login-image.php

    NOT:
    mu-plugins>login-image/login-image.php

    Also, what are your file permissions?

  • deefisher
    • WPMU DEV Initiate

    The files are in the mu-plugins directory, without any subdirectories. I changed the permissions on that folder (and its files) to 777 temporarily, but it didn't help.

    I also deleted the mu-plugins folder altogether, created a new one, and re-uploaded the files.

    I'm 99% sure it's something simple...

  • deefisher
    • WPMU DEV Initiate

    Found the problem. Did a complete new install with new database. Everything worked fine. Installed the wpmu-nelo theme (new version), and the widgets broke. They appeared in the inactive widgets, but wouldn't work when placed in the page. I'll obviously be using a different theme!

    Not sure how to mark this thread as solved, but it is!

    SOLVED

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.