Avatars for Multisites broken in user profile

On my network site users are able to change their avatar from the menu Settings > Blog Avatar but not from their Profile. Here are the URLs, respectively...

/test01/wp-admin/options-general.php?page=blog-avatar
/test01/wp-admin/profile.php?page=user-avatar

No doubt the url from the members profile page is the culprit. How can I change it? If no way to change it, removing avatar from showing in the profile editing page would work as well, since there is the link in the menu to manage the avatar.

I'm running WordPress 3.4.1 and Avatars for Multisite 3.5.7.1 network enabled. Avatars for bbPress is disabled, as I'm not running bbPress.

Not sure if it matters, but I have my WP install on a subdomina - sites.mywebsite.com and setup to use subdirectories, thus Test01 is at sites.mywebsite.com/test01/etc...

  • Tedster
    • The Incredible Code Injector

    Hi Kimberly,

    I'm not using buddypress and I do see the avatar switcher in the profile, as shown in your image.

    I'm doing a complete reinstall, since I don't have any members yet. However, I should clarify it seems to be a permissions issue - when I use the link from the profile I get the message that I do not have the proper permissions to view that resource, or something to that order.

    Using the link from the admin menu works fine. Here's what happens...

    Link from menu works fine > /test01/wp-admin/options-general.php?page=blog-avatar

    Selector in profile says no permission > /test01/wp-admin/profile.php?page=user-avatar

    Do your two places to change the avatar also go to 2 different urls, as mine does?

    Since I'm doing a fresh install, I'll activate the blogs avatar plugin first, and check it with each other plugin I install, to see if I can locate a conflict.

    Ted

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.