Avatars not displaying or uploading correctly

Hi there, the avatars are not successfully uploading. I get to the part where it asks how I would like to crop it and I can see the image but then it doesn't show up. This is on a site where when I updated marketpress to 3.0 I have had significant problems. See thread. https://premium.wpmudev.org/forums/topic/fatal-error-on-marketpress-update#post-1081418
This avatar problem is not occurring on the live site that has not updated to marketpress 3.0.7 it is only happening on this staging site with the most updated marketpress. I think the avatar problem may be related to all my marketpress issues discussed in the thread above. I have allowed access to dash.

  • Leslie
    • The Crimson Coder

    Maybe it has something to do with her role as "subsite admin" I had to add that role a while back for some permissions errors that didn't allow her as the administrator to do anything. We couldn't figure it out so we just added another role and it solved the problem but now I am having other problems with it obviously.

  • Rupok
    • Support Ninja

    Hi Leslie, hope you had a wonderful day.

    now I am having other problems with it obviously

    Can you please open a new thread with your other problems (if not opened yet)? Our expert and friendly support staffs will take care of those within no time.

    Please let us know if you have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Leslie
    • The Crimson Coder

    Not sure the subsite admin role is causing the issue with Avatars. It was just something to explore in the context of the Avatar problem. If this added user role continues to be a problem, I will open another support ticket regarding it. Any ideas on which direction to go on this problem?

  • Rupok
    • Support Ninja

    Hi Leslie, hope you had a wonderful day.

    Maybe it has something to do with her role as "subsite admin"

    Thanks for granting Support Access. I logged in your site but I could not find the user whos avatar is not showing. Can you please tell use which user to check? We can check in details then and try to solve the issue faster.

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Nithin
    • Support Wizard

    Hi Leslie,

    Hope you are doing good today. :slight_smile:

    I checked your website, and was able to replicate the issue when I created a new user in your website, it seems more like a plugin conflict. I tried to replicate the issue along side MarketPress plugin, but it didn't. Could you please run a plugin conflict test, and rule out any plugins causing a conflict. Even avatars plugin had a recent update, maybe causing some conflicts.

    Please check the flowchart for more info: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Kasia Swiderska
    • Support nomad

    Hello Leslie,

    Please enable debug log in your site and try uploading again avatar to that user. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see contents of the debug.log file - so please paste it to the text file and attach to post or upload to service like Dropbox and paste here link.

    kind regards,
    Kasia

  • Leslie
    • The Crimson Coder

    ok, here is the error log after trying to upload a new avatar on the user's dash.
    [Thu Jun 02 15:02:36.476669 2016] [:error] [pid 12233] [client 166.137.14.75:52830] PHP Warning: Missing argument 2 for update_site_option(), called in /nas/content/staging/ecraft/wp-content/plugins/avatars/avatars.php on line 142 and defined in /nas/content/staging/ecraft/wp-includes/option.php on line 1057, referer: http://ecraft.staging.wpengine.com/wp-admin/network/plugins.php

  • Ash
    • WordPress Hacker

    Hello leslie

    I have just tested the plugin in my test site and it worked perfectly fine in there.

    I have checked your site, and found the avatar URL is: http://xxx.xxx.wpengine.com/avatar/blog-533-96.png?rand=1912aec266212d39fcf775a3e9d337e3

    But when I visit this URL, it redirects back me to http://livedomain.com/

    Would you please contact your host about this? Just in case if they have any rule in their hosting?

    Have an awesome day!

    Cheers
    Ash

  • Leslie
    • The Crimson Coder

    Hi Ash, your comment prompted me to think it was just a symptom of being on the staging site and since this was my only issue to pushing live, I decided to go ahead and push live and see what happens. The avatars are showing up correctly on the new live site so yes, it was probably an url address mistake in the database for this particular subsite back when I created the staging site.
    thanks for your insight into the problem and for everyone's contribution too.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.