Back Up not working - Snapshop Pro

The HUB keeps telling me that I need to perform a back up " No backups". When I click through to run a back up, deactivate the scheduled back up that never seems to run, and click manual backup, it goes through all of the processing steps, then always comes back with "Aw shucks, something went wrong: (instead of the beautiful response we expected, we got this:"

It's always the same basic hodge podge of the admin bar. See here: http://prntscr.com/cyvfov

Happens with ALL of my sites. not one of the 5 that I currently have synced work.

I have tried turning off unnecessary plugins to see if there could be a conflict, but still get the same issue.

This is one of the features/plugins that makes this membership worth it. I'd prefer not to just have snapshots on the same server in case there's a hack, or server failure.

Thanks for the help.

Estevan

  • Kasia Swiderska

    Hello Estevan,

    I can see issue on your site - I would like to see what is returned in debug log when Snapshots fails. Please enable debug mode in WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - so please upload it to Dropbox like a service and paste here link.
    Of course when you enable it run managed backup again so errors will show in debug log file.

    Does all your sites are on the same server? Could you tell me what is your hosting company?

    kind regards,
    Kasia

  • Estevan

    Kasia,

    Thank you for the response. I will follow the debug steps and post the files shortly.

    To answer the last questions:
    - No, they are not all on the same server. 4 different servers in all.
    - 3 of the servers are Godaddy, the other is HostRocket.

    In double checking that it is impacting all of the sites and it is on all servers, I found another odd issue.
    - *****golf.com has a backup in the WP admin, but the wpmudev dashboard is still alerting me that there is no backup. It's set up with snapshot, but last backup was stored locally. I still get the "aw shucks" message when trying to backup.

    I'll update shortly when I have the debug files.

    Thanks,
    Estevan

  • Estevan

    Kasia,

    Here's a link to the debug.log: https://drive.google.com/file/d/0BxtuuKPf196MZ3pTcE9Va3BnVEU/view?usp=sharing

    One of the sites that is hosted on Godaddy's Wordpress Managed package was able to get the back up to work with the remote backup setting. The others still throw errors. I'm testing the other in the similar hosting environment to see if it too works. However, the multi-site install on HostRocket, and the Multi-site and standard (the debug is for this standard) with Godaddy Linux hosting still "aw shucked"

    Thanks for the continued support. Hopefully the debug.log helps.

    Estevan

  • Kasia Swiderska

    Hello Estevan,

    So debug log didn't help... There are two notices from other plugin and that all. Please confirm that after enabling debug you did run again backup - Im asking for that because regarding to that debug log nothing happen...
    That is weird.

    This might be long shot but run a quick plugin conflict test as illustrated in getting support manual (flowchart) - with all plugins disabled run backup. Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    kind regards,
    Kasia

  • Estevan

    Kashia,

    It's been a few week since I've had a few moments to circle back on this. For starters, I've deactivated and uninstalled snapshot from all of my clients sites. It was causing the sites to go down/ be unresponsive from a server level due to resources issue / during the attempted back up time at 2am.

    In addition, I've just tried, and re-tried the back up on my agency site: http://thinkbrightmarketing.com/ - I've turned off all plugins other than the WPMU and again with just Snapshot and the WPMU dashboard, and still get the same error.

    The themes that I have tried and been unsuccessful with are rather popular.

    https://themeforest.net/item/shopkeeper-ecommerce-wp-theme-for-woocommerce/9553045
    https://themeforest.net/item/foundry-multipurpose-multiconcept-wp-theme/12468676
    https://themeforest.net/item/renovate-construction-renovation-wordpress-theme/11789093

    Lastly, I swapped out to a standard theme 20 15. When running the back up on my site, the site and server hit all resources and my IO usage was maxing out 1024/1024, and the backup took over an hour to attempt. Should this be so resource intensive? It did successfully back up under the condition that NO other plugins existed. But given the time and resources to run a back up, I do not have the luxury of turning the plugins back on one by one.

    Any assistance would be appreciated, as the backup that was just run is useless, as it does not reflect my actual site.

    Thanks,

  • Nithin

    Hi Estevan,

    Having a low memory limit, and max_execution_time could also affect the backup, if you are finding your website maxing out, you could try increasing the memory limit. Since, the support access is not enabled, I'm not able to check your current server settings.

    To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 256M
    post_max_size = 512M
    memory_limit = 1024M
    file_uploads = On
    max_execution_time = 300

    Since I'm not able to check your current configuration, the above value, is just an example. Please change it accordingly.

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If you still have issues, please enable support access so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Estevan,

    Hope you are doing good today. :slight_smile:

    There isn't any specific recommend memory setting, it entirely depends upon your server, and how your server is handling the available resource. If you server is maxing out, or running out of memory resource, then you'll have to increase your memory limit, and these values depends upon each server, and whether the hosting provider places any restrictions on increasing the memory limit.

    If you are sure that increasing the memory limit should solve it, you could just double the current settings, and check whether it helps.

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin