background images not showing when using upfront

Some background images are not displaying when viewing the site on firefox. Please help?

  • Predrag Dubajic

    Hey bloomingmountain,

    Hope you're doing well today :slight_smile:

    I had a look at your site and it looks like issue is not related to browser, it actually seems that images are not displayed when you're logged out.

    I was able to find similar report for this and that user was also hosting his site on GoDaddy, he ended up contacting them and they cleared server cache that fixed the issue.
    Could you try contacting GoDaddy support and see if this works for you as well?

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello bloomingmountain!

    I checked the site and it seems that at the moment all shows up for me in Firefox. I also checked this using responsive view tool and both menu and images seems to be working.

    As you said it's not quite reliable but also - due to your experience - we can, I think, confirm that it's related to GoDaddy's cache I think if that happens again it may be good to get in touch with GoDaddy againa and ask them to review server logs. I mean: I hope that either they would be able to find a permanent solution or at least it would give us some clues on why that's happening and I could then pass that to our developers to help them improve Upfront more.

    I'd appreciate very much if you could ask them about it and pass their replay to me as well!

    Best regards,
    Adam

  • Dimitris

    Hello bloomingmountain,

    hope you're doing good and don't mind chiming in! :slight_smile:

    I am having similar issues with another site as well. Please help

    Could you please point to us the second website with this issue?

    I have never had an issue with the godaddy shared wordpress hosting before....so I am not ready to pin it all on them. There must be something weird about the site setup.

    Having some feedback from them may be valuable for us too. It seems that their hosting is interfering with UpFront in a bad way, so the solution may lies somewhere in between. It may be something that can be taken care of by us or by them.
    Did you had any UpFront sites working before in this shared account or are these your first instances? Please advise! :slight_smile:

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello bloomingmountain!

    Godaddy said that since it is a shared hosting environment, that there are no server logs available.

    Thank you for contacting them. I must say I'm surprised with their replay because usually there is some kind of logs available for you even in shared environment but even if not, they must have access to their system and its logs so they probably just don't want to share it or bother with looking into it.

    That means that we'll need to take different approach but I admit I'm not yet quite sure what way to go then. I hoped that the logs will give us some clue (as it usually is) and at least point in some direction.

    So, I visited your site again and can see that now some images are not showing up for me. That's actually a good thing in this case because because of that the site also generated some errors in a browser console that I wasn't able to spot before. Those however again seem to confirm that there are some caching issues which somewhat puts us in a kind of a loop.

    To further diagnose this I made (temporarily) some changes to the Upfront settings on your site and was able to both break the site completely and get it fully working. None of these states though was permanent (which confirms your findings).

    I did notice though that your WordPress is running on a lowest possible amount of memory which may be causing interference with all the caching features of both your server and Upfront. That's something that I should suggest at the very beginning so I'm sorry for not doing this. That said, please add following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','256M');

    This line should be located above the "/*That's all, stop editing!*/" line. Once it's there please:

    - go to "Upfront -> General" and use "RESET UPFRONT CACHE" button
    - open your front page in browser (while being logged in) and use "GoDaddy -> Flush Cache" link in admin toolbar

    Then clear browser's cache and see how the site performs. I think it should load images but let's then see how this will affect stability.

    Keep me updated please!

    Best regards,
    Adam

  • Dimitris

    Greetings bloomingmountain,

    hope you're doing good today!

    I was about to raise the memory limit to 256M using a .user.ini file, which is the way they said to do it on the shared hosting environment. It is still not working reliably though. It looks like the images are loading now, and sometimes the page layout is distorted and the page is all messed up with elements in different places and not laid out as they should be.

    Could you please try to re-raise this memory limit value to 512M and test again?

    Clearing the caches like my colleague Adam mentioned in his previous reply, didn't have any effect?

    - go to "Upfront -> General" and use "RESET UPFRONT CACHE" button
    - open your front page in browser (while being logged in) and use "GoDaddy -> Flush Cache" link in admin toolbar

    I'm wondering as the "sometimes" part of your reply, points to cache issue more or less... :thinking:
    Please advise!

    Warm regards,
    Dimitris

  • JOinAZ

    Dimitris-
    I read through the entries about the issue you are having and I am having the exact same issue. This has been weeks of trying to get something resolved. I clear the cache regularly, update permalinks etc. and it works occasionally but not reliably. It seems when I deactivate a plugin or make a significant change it corrects the problem temporarily but then goes right back to the same issue. My site was working fine yesterday until I did a theme update - then back to the same problem - so I reverted back with a backup I did but it didn't help. I have ready adding a line of code to force loading of images might be a solution but I'm not a developer and I don't even know if that will work. Just thought I would let you know about my situation because GoDaddy doesn't seem to be cooperating and I can't prove it's on their end either. Hope this works out for you - I will let you know if I make progress. Good luck! JO

  • JOinAZ

    Hi BloomingMountain -
    I wanted to let you know I got my issue resolved and since it sounded so similar to your problem I thought you might benefit from giving it a try. I renamed the wp-content folder wp-content1 then reset cache in wp-admin panel with the "flush Cache" selected from the Godaddy top menu bar drop-down. Then rename wp-content1 folder back to wp-content. This does a hard reset for objects and did the trick for me. Good luck:slight_smile: JO

  • JOinAZ

    BloomingMountain - Hi again -
    I wanted to correct something I wrote earlier when I was in a bit of a hurry. I mentioned renaming your wp-content folder which is not accurate. It was the cache files inside the wp-content folder. I have attached a screenshot of the files for your reference. You can access these files through your C-panel or if you are using their managed WordPress pro with no C-panel you can use FileZilla to get access which is what I had to do in this case. If you use FileZilla you will need to get settings from your GateWay GoDaddy Panel (https://gateway.godaddy.com/Settings - SSH&SFTP tab) - you will need your host (IP address or domain name), username, password and port 22. Then go to WP-contents folder and rename files object-cache.php and wp-cache-config.php to object-cache1.php and wp-cache-config1.php. Then go to your WP Admin Dashboard and in the top menu, use the GoDaddy drop-down menu to Flush Cache. After you do this, return to FileZilla or C-Panel and rename object-cache1.php and wp-cache-config1.php to object-cache.php and wp-cache-config.php. This should resolve the issue - if the issue we are having is the same. Side note - I did this yesterday but today I had to re-do it. I am trying to figure out what is causing it - maybe additional caching from Hummingbird??? - but not sure - at least I have a fix for now. If I figure out what is causing it I will post. If you find out what the culprit is, I would appreciate hearing from you. Sorry for the lengthy post but wanted to clarify my statement so I didn't point you in the wrong direction. Good Luck! JOinAZ

  • Dimitris

    Hey there MSAMike,

    hope you're doing good and don't mind chiming in!

    As this is a rather old thread with more members involving, could you please create a new thread about your UF GoDaddy issues? A representative from our team will be in touch with you as soon as possible! :slight_smile:
    https://premium.wpmudev.org/forums/#question
    https://premium.wpmudev.org/docs/getting-started/getting-support/
    We tend to keep threads related to specific member and issue so that more WPMUDEV support staff member can follow-up (if needed) and of course we produce more useful threads for future users.

    Warm regards,
    Dimitris