Backup doesn't work, not local, not remote managed

Hi,

Since a couple of weeks the snapshot plugin stopped working properly.
At first the daily snapshot I setup for local backups stopped working. It doesn't work even if I start the backup job manually.
Then since the 9th the managed backup to the WPMU dev servers stopped too.

Please, can you help?
I already granted wmpudev dashboard access linking to this thread.

Thank you so much in advance for this help.

  • Dimitris

    Hello Manohar,

    hope you're doing good and thanks for reaching us!

    At first the daily snapshot I setup for local backups stopped working. It doesn't work even if I start the backup job manually.

    It's true that I can't see any previous snapshots, just like I can see previous managed backups.
    Did you perform any change in your website at around March 9th? Please advise!

    Also, I find it a bit excessive to have two daily snapshots, one local and one in the cloud, but that's your call of course. My main concern is server resources but you may track this better, if it isn't any issue for you.

    Could you please access your server via FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    Then go ahead and try to re-run your snapshot but before doing so, please temporarily disable managed backups so we can have clearer logs.

    After the snapshot procedure, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply.
    If filesize of text file is larger than the 5MB limit of our forums, please use a service like Dropbox and post the shareable link instead.

    Also, please inform us about any messages on screen during backup procedure.

    Warm regards,
    Dimitris

  • Manohar

    Hi Dimitris,

    Thank you for the suggestions.

    The website is in full development. There were many changes in the last weeks. I can't tell what exactly what changes happened on the 9th.

    I did what you asked about the debugging, the only message I received on the dashboard was "Item scheduled to run", then nothing happened. The backup was never created.

    I've attached the log file.

    I hope this is useful, thank you for the help,

    Manohar

  • Dimitris

    Hey there Manohar,

    hope you're doing good today!

    I reviewed the debug file but there is nothing relevant in there. As this is a website in construction, and I presume this is a shared hosting environment (?), you can try to deactivate all caching and optimization plugins like W3 Total Cache and HummingBird (you can set these up when you're in a "production-ready" state) and maybe lighten up your snapshots.
    I wonder if this is a matter of resources, despite the fact that I've run snapshots in shared environments.
    You can try to exclude theme and plugins folders, or uploads folder and try to create it once more.
    Let me know if that makes any difference at all.

    Warm regards,
    Dimitris

  • Manohar

    Hello Dimitris,

    I've checked the issue. I've completely uninstalled the W3 plugin and tryied the backup with Hummingbird de-activated and the Snapshot plugn still doesn't work.

    I don't think this is a resource problem. We have a powerful cloud hosting package to support this website.

    Could you please check the plugin again? Perhaps it's settings or other possible conflics.

  • Adam Czajczyk

    Hello Manohar!

    Thank you for granting access again.

    I have reviewed the debug.log once more time (just in case) and checked site's settings again. That all looks fine. I did notice however that your snapshot is set to use Managed Backup schedule and the last time it was performed was on April 11th. I think the "snapshot" might be fine itself as that last one completed fine and it only doesn't work because it's tied to the Managed Backup (which is not working).

    That said, I made two changes to the site:

    1. I have deactivated Managed Backups schedule (to stop all possibly running processes), changed error reporting level for it and scheduled it again

    2. I have changed "snapshot" interval from "Daily Managed Backup" to "Once a daily" and set it to start at a different time than Managed Backup.

    That way, the "snapshot" should run independently from "Managed Backup". That would show us if that part works right. Also, I hope that with current "error reporting level" Managed Backups will give us more information about what is happening on the site.

    Let's now see if these backups complete, so let me know about it please.

    Best regards,
    Adam

  • Manohar

    Hi Adam!

    Thank you for your help. But unfortunately the issue remains unsolved.

    It was never a problem of selecting the right kind of setup.
    The plugin was working fine until March when I tried the UpdraftPlus WordPress Backup Plugin. Then it stopped working altogether.

    I would like to have the managed backups to work at first. The local backups are a welcome bonus.

    I've granted support access again. Could you see how to solve this issue?

  • Dimitris

    Hey there Manohar,

    hope you're doing good today!

    I tried to access your website via the support access but I'm getting an error message instead that the page doesn't exist.

    I presume this is happening due to a security plugin, could you please deactivate it while we're working on this?

    If you'd rather not, please send us your WP admin credentials (and by the chance share some FTP details too!). As this is public forum, you should send us your details through our safe contact form https://premium.wpmudev.org/contact/#i-have-a-different-question using this template:

    Subject: "Attn: Dimitris"
    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.

    Warm regards,
    Dimitris