backup issues, seems like it's only the remote backups affected

Both methods for remote backup I've setup are not working any more? The managed backup does not run at set interval and returns null_response when run manually, log file does not display anything either.

Snapshots are only working locally, I do have valid connection to my google drive folder and the connection is authorized, but the file never arrives although the snapshot did complete.

both stopped working on the 3rd, so strange?

  • Sajid

    Hello Staq,
    Hope you are doing good today

    Did you tried making a plugin/theme conflict test as described in our getting support manual or see the flowchart attached below.

    If that does not turn out to be a conflict then please reset the Google Drive connection and then check again.

    Also, the managed snapshot does not work for you either (Snapshot -> Managed Snapshots) ?

    Please enable support staff access so we could take a closer look. To grant access go to Dashboard -> WPMU DEV -> Support -> Support Access -> Grant Support Access or see this manual for more details regarding how to enable support staff access.

    Take care and have a nice day

    Best Regards,
    Sajid - WPMU DEV Support

  • Staq

    Hello,
    All plugins were disabled except; Domain Mapping, Multi-Domains for Multisite, Pretty Plugins, Snapshot, Upfront Builder, WPMU DEV Dashboard. during the test, the snapshot stated that there was success backup. I check the log file in the upload/snapshot directory and found the following:

    2017-04-09 16:43:00: Sending Archive: snapshot-1491576261-170407-144421-c5188273.zip 123.63 MB
    2017-04-09 16:43:00: Destination: google-drive: google-j
    2017-04-09 16:43:00: Connecting to Google Drive
    2017-04-09 16:43:00: Sending file to directory: 0B9nm5RM-cDMCTUE2cWVYaVlRVDg
    2017-04-09 16:43:00: ERROR: Error: Could not send file

    Google_0814_Exception: Failed to start the resumable upload in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php:290
    Stack trace:
    #0 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/Google/Http/MediaFileUpload.php(138): Google_0814_Http_MediaFileUpload->getResumeUri()
    #1 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(336): Google_0814_Http_MediaFileUpload->nextChunk('PK\x03\x04\x14\x00\x00\x00\x08\x00\x92u\x87J\xAA...')
    #2 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/lib/Snapshot/Model/Destination/google-drive/index.php(280): SnapshotDestinationGoogleDrive->send_file('/opt/bitnami/ap...')
    #3 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/snapshot.php(7038): SnapshotDestinationGoogleDrive->sendfile_to_remote(Array, '/opt/bitnami/ap...')
    #4 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/snapshot.php(6918): WPMUDEVSnapshot->process_item_send_archive(Array, Array, Object(Snapshot_Helper_Locker))
    #5 /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/snapshot/snapshot.php(7257): WPMUDEVSnapshot->process_item_remote_files(1491576261)
    #6 /opt/bitnami/apps/wordpress/htdocs/wp-includes/class-wp-hook.php(298): WPMUDEVSnapshot->snapshot_remote_file_cron_proc()
    #7 /opt/bitnami/apps/wordpress/htdocs/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters('', Array)
    #8 /opt/bitnami/apps/wordpress/htdocs/wp-includes/plugin.php(515): WP_Hook->do_action(Array)
    #9 /opt/bitnami/apps/wordpress/htdocs/wp-cron.php(117): do_action_ref_array('snapshot_remote...', Array)
    #10 {main}
    :Failed to start the resumable upload

    The log file viewer reports the following error:
    [Cron][2017-04-09 16:30:46][Warning] Immediate hook misfired, kickstart backup processing

    support access granted

  • Denitsa

    Hello Staq,

    Glad we had the Google Drive issue resolved, we're getting to the bottom of this.

    Please make sure you have no manual backups running and temporarily disable automated backups. Then, can you open your wp-config.php file via FTP and add the following above the /* That's all, stop editing! Happy blogging. */ line

    define('WP_MEMORY_LIMIT', '256M');
    
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    After you made those changes, try running a backup again (you can try with both manual and managed backups). There will be a log saved to a debug.log file inside the "/wp-content" folder. Please save the file as a .txt and attach it to your next post.
    If the file's larger than 5MB you might need to upload it somewhere like Dropbox and share the link here.

    Let me know how it goes!

    Regards,
    Denitsa