Backup process returns

I'm trying to get manual backups to work but it returns this error: <empty response>

What is causing that and what can be done to fix it?

BTW, I am also running iThemes Sync and BackupBuddy. I turned it off but now I can't find where to run a manual backup to test it. Where the heck is that screen?
Also, is there a known conflict you know about anyway?

  • Kasia Swiderska

    Hello jamesb303,

    Are you trying to do managed manual backup or standard Snapshot? If managed and you don't have anymore button to do manual backups then decativate scheduled backups on page /wp-admin/admin.php?page=snapshots_full_backup_panel

    and after that you should see button again.

    As for the empty response it there might not enough resource for snapshot on your server. Can you please try the solution Predrag Dubajic provided here: https://premium.wpmudev.org/forums/topic/an-unknown-response-returned-from-snapshot-backup-attempt#post-1094124 and check if you can backup without any problem?
    If possible set max_execution_time to at least 180.

    Let me know if this will help.

    kind regards,
    Kasia

  • jamesb303

    I'm a little confused by your tips. But here is what I tried.

    I deactivated the scheduled backup I had set up and tried a manual backup. But I got that same error.

    Then I added that code "define('WP_MEMORY_LIMIT', '256M');" to my wp-config.php file. Same error.

    I couldn't locate the PHP.ini file so I tried adding the code "php_value memory_limit 256M" to my .htaccess file. It generated a bunch of errors so I thought the code was placed in the wrong place in the file. So I tried it in a few different places.

    Then I tried creating a Snapshot with Add New. It ran until the Files: media section and stopped with this error "An unknown response returned from Snapshot backup attempt. Aborting. Double check Snapshot settings."

    I went to Snapshot > Settings > Server info section and clicked on the WPMU DEV Dashboard plugin link and at the top of the page it read "Warning: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in /home/content/p3pnexwpnas08_data03/36/2737936/html/wp-content/plugins/wpmudev-updates/template/support-system.php on line 77?

    Any ideas of what to do from here?

  • Nithin

    Hi jamesb303,

    Hope you are doing good today. :slight_smile:

    It seems like the support access is disabled, so I'm not able to check your current settings. Could you please enable support access, so that we could give a closer look. Regarding php.ini file, you'll have to create it manually in your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    Please check this link for more info:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If you have already tried this, and you aren't able to increase your memory limit, would recommend you to get in touch with your host, in order to increase these values.

    Warning: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in

    Are you running PHP v 5.4? If yes, could you please upgrade it to at least a minimum recommended version of PHP 5.6, and see whether it helps.
    https://wordpress.org/about/requirements/

    Please let us know once you grant support access, so that we could give a closer look. You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual: http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Kind Regards,
    Nithin

  • Kasia Swiderska

    Hello jamesb303,

    Your max_execution_time is set to 30 and this is bit low for Snapshot. It would be best if you could really increase that and also update php to higher version.

    Also please try adding this line to your wp-config.php file:

    if (!defined('SNAPSHOT_FILESET_CHUNK_SIZE')) define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);

    before line
    /* That's all, stop editing! Happy blogging. */
    But before you do that change make sure that no manual backups are running and automated backups are disabled. Then run manual backup.

    Can you also tell me who is your hosting provider?

    kind regards,
    Kasia

  • Nithin

    Hi jamesb303,

    Hope you are doing good today. :slight_smile:

    I do see that you are still having memory limit as 256M, and max_execution_time as 30. Since you did mention it's GoDaddy, the changes made in php.ini file which was mentioned above will not reflect immediately.

    To increase max_execution_time, please try creating .user.ini file in your root directory, and add the following rules to it:
    max_execution_time = 180

    To increase memory limit, please try adding the following code in your wp-config.php file, which is located in your root directory:
    define( 'WP_MEMORY_LIMIT', '512M' );

    Please make sure to place the above code, just before the line /* That's all, stop editing! Happy blogging. */

    Please let us know whether performing these changes, makes any difference, and please let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • jamesb303

    I tried adding the .user.ini file. Note that I don't have access to create files from a File Manager like they talk about in this article since I'm on Managed Wordpress. https://www.jabari-holder.com/blog/how-to-create-godaddys-user-ini-file/
    So I copied a file named "en-GB.com_user.ini" that I found in the backup of one of my other sites. I deleted all the code in it and put the two lines you gave me in there and saved it as a .user.ini file. Note that it did not have the code that reads "/* That's all, stop editing! Happy blogging. */" Hope that is alright to just have those two lines in there.
    Then I uploaded it to the GoDaddy root. Waited 8 minutes and clicked the Backup Now button in the Managed Backups section. It got to at least step 113 before I noticed it stopped with the <empty response> error.

    If you think it has to do with the code in the .user.ini file, can you send me a sample of the exact code that needs to be in the file to be complete?

  • Nithin

    Hi jamesb303,

    It seems like the support access is disabled, so I wasn't able to check your website. You can check whether the above changes made have increased the max_execution_time, and memory_limit, under WPMU DEV > Support > SYSTEM INFO
    [image pos="0"]

    If not, you'll have to get in touch with your host in order to increase these values.

    If you think it has to do with the code in the .user.ini file, can you send me a sample of the exact code that needs to be in the file to be complete?

    What I mentioned above is the rule which should increase max_execution_time, other than that there isn't any other code that's needed at the moment. You just have to place the code in the last last line of .user.ini
    max_execution_time = 180

    You might find the link helpful:
    https://www.jabari-holder.com/blog/how-to-create-godaddys-user-ini-file/

    If you are still having doubts regarding would recommend you to get in touch with your host. Pelase let us know how that goes. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • jamesb303

    Thanks Nithin,

    I logged into SkinEsthetics.com and I checked and it is showing max_execution time 180, memory_limit 256M, upload_max_filesize 64M and post_max size 65M in the WPMU dashboard.

    I also noticed an error when I went into that support page too. Maybe this is a clue?
    "Warning: mysqli_get_server_info() expects parameter 1 to be mysqli, resource given in /home/content/p3pnexwpnas08_data03/36/2737936/html/wp-content/plugins/wpmudev-updates/template/support-system.php on line 77

    I tried a backup again but got the same <empty response>

    I opened up support access again for another 5 days in case you need to get in there.

    What next?

  • Nithin

    Hey jamesb303,

    Hope you are doing good today. :slight_smile:

    I also noticed an error when I went into that support page too. Maybe this is a clue?

    The message is more of a warning, and it shouldn't break the plugins backup process. I believe, the message shouldn't appear for installs having PHP v5.6, and above.

    To troubleshoot this issue further, could you please enable debug mode, so that we could have a better idea about this. To enable it, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    After making the above changes, please perform a new backup. If the backup fails, the errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    Please let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • jamesb303

    I'm still getting the errors, pretty much immediately when I start a backup.

    I'm not getting the debug.log file either.

    I changed that one line and added the other two but it isn't generating a debug.log file. Here is what I added.
    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);
    I wasn't sure if the spaces or lack of next to the parenthesis ( ) were critical so I tried it both ways, with and without.
    Any ideas why it might not be creating that file? Or backing up?

  • Kasia Swiderska

    Hello jamesb303,

    I think we need to take much closer look what is happening there. Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include cPanel credentials
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm here that you send that message to us

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello jamesb303,

    Thanks for sending that. Debug.log was created and it was quite big one - but sadly there was no error or warning from Snapshot. There are errors and warning from other plugins and this makes me wonder if that is not related - that this is indeed conflict there.
    Please run a quick plugin/theme conflict test as illustrated in getting support manual (flowchart). Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I also disabled debuging on your site, because files were getting bigger and bigger very fast. You can delete debug.log1 file - this one is from before I started testing.

    kind regards,
    Kasia

  • Nithin

    Hi jamesb303,

    Hope you are doing good today. :slight_smile:

    I checked your system, and I did try to perform a backup with the plugins disabled, but I'm getting the same result as you have mentioned, and unfortunately the debug logs doesn't help much either. To sure whether any requests isn't being blocked in your system, could you please share your recent server log, so that we could give a closer look.

    If you aren't sure about where to check for server log, would recommend you to get in touch with your host, in order to get the recent logs.

    I accidentally deactivated the Snapshot plugin, so please re-activate Managed Backup, by entering the secret key, under Snapshot > Managed Backups.

    You can make use of cloud services like Dropbox, or Google Drive to share the link to your server log. Please let us know how that goes, so that we could help get this sorted. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.