Backup using snapshot fails

Hi, when I try to do a first time backup using Snapshot, it constantly fails and gave me this message

"Aw shucks, something went wrong :slight_frown: Instead of the beautiful response we expected, we got this:

<empty response>

What can I do to resolve this? I have granted access to your superheroes

  • Kasia Swiderska

    Hello Jeffery,

    I can't check your site because there is error "Your session has expired because it has been over 120 minutes since your last login. Please log back in to continue." - if you have any security plugin can you disable it?

    For the Snapshot, please try increasing memory limits especially max_execution_time to at least 180 https://premium.wpmudev.org/blog/increase-memory-limit/
    Your current limits can be found in WPMU DEV -> Support -> System Info. Let me know if this helps

    kind regards,
    Kasia

  • Jeffery Seah

    Hi Kasia,

    I must apologise for the delayed response. Something happened in the home front that took me away from this for the past weeks.

    I can access the WPMU DEV -> Support -> System Info and see the max_execution_time is at 30. But I can't make any changes to it. And right now, I'm still unable to backup my site. And I'm too afraid to make more changes to the site or install more awesome plugins from WPMU Dev because I still can't backup my site.

    Also, I've disabled my security plugin and granted another new access to my site. Hope that you will be able to go in and see what's wrong this time round.

    Cheers
    Jeffery

  • Nithin

    Hey Jeffery Seah,

    Hope you are doing good today. :slight_smile:

    I'm afraid, I'm being redirected to a login screen when I try to access your website, to get this sorted faster, could you please send us your credentials so that we could give a closer look at this, and have a better understanding of the websites issue.

    You can send credentials by using our secure contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    - To Mark to my attention, the subject line should contain only: ATTN: Nithin Ramdas
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Nithin

    Hi Jeffery Seah,

    Hope you are doing good today. :slight_smile:

    Thank you for sending your WP login credentials, I checked your system, and performed a full backup, and I could see the error what you have mentioned. I was able to notice 500 error in the console related to the response being called, this seems more related to your configuration, you'll have to increase your memory limit, and max_execution_time in order to get this working.

    I can access the WPMU DEV -> Support -> System Info and see the max_execution_time is at 30. But I can't make any changes to it

    Did you meant your host doesn't allow you to make any changes to it, or you don't know how to make changes?

    To increase your memory limit, you'll have to create a php.ini file inside your root directory, and add the following rules to it:
    For eg:

    upload_max_filesize = 128M
    post_max_size = 256M
    memory_limit = 512M
    file_uploads = On
    max_execution_time = 300

    Could you please get in touch with your host, if you aren't sure how to make these changes. Please do let us know how that goes, have a nice day. :slight_smile:

    Kind Regards,
    Nithin

  • Jeffery Seah

    Hi Nithin,

    Not sure if I'm asking the right question to my host. I'm on shared hosting and according to Hostgator, it doesn't allow changes to max_execution_time? Could this be the case? Does it mean we need to be on dedicated servers to use snapshot? All this is too technical for me.

    If you need my cpanel access to have a look I'll be happy to provide them. Right now I'm afraid to meddle too much with the plugins and themes before I can do a full backup using snapshot.

    Anyway, do you guys offer services of revamping websites for a fee? My site is getting old and bogged down with a lot of old plugins and old theme. I'm hoping I can change them to WPMU dev theme and plugin for ease of use in future.

  • Nithin

    Hey Jeffery Seah,

    Hope you are doing good today. :slight_smile:

    Not sure if I'm asking the right question to my host. I'm on shared hosting and according to Hostgator, it doesn't allow changes to max_execution_time? Could this be the case? Does it mean we need to be on dedicated servers to use snapshot? All this is too technical for me.

    For Snapshot plugin to backup without any issue, it'll need to have a higher max_execution_time, and memory_limit than the current settings. We are increasing these values because, the files in your system is large, and the plugin will need more resources for it to process it's requests. It isn't mandatory to run the plugin on dedicated servers, it should work fine in servers where you can increase these mentioned values, and it entirely depends upon each host, whether you can increase these values, or not. Shared hosting does have such limitations, but the current settings is too low for full managed backup to process your large files.

    If you need my cpanel access to have a look I'll be happy to provide them. Right now I'm afraid to meddle too much with the plugins and themes before I can do a full backup using snapshot.

    I just checked the Hostgators manuals, and I could see that these settings cannot be changed for Hostgators shared hosting. I'm afraid, there isn't any option to make it work, other than increasing max_execution_time, and memory_limit.

    Anyway, do you guys offer services of revamping websites for a fee?

    We don't provide any such services for a fee at the moment, you'll have to check the Jobs & Pros, in order to get this sorted with a help of a professional. Please do note that members found in the Jobs & Pros section are individuals, and not affiliated with WPMU DEV in any way.

    I hope this helps. Please let us know if you still need any further assistance. Have a nice day. :slight_smile:

    Best Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.