[Backups] Backups Won't Backup Anything, Doesn't Even Begin To, From Neither Site Or Hub

This site we manage used to backup using Backups. However, for many months now it has failed to backup. I don't even think it even begins, and it for sure doesn't complete. It just spins and does nothing. We get the same results (of nothing working) whether we initiate a backup from the admin of the site or whether we do it from the Hub. Not sure if this is an issue with our server or what it is. Any help / suggestions would be appreciated. We've gone ahead and opened up the support portal for troubleshooting access. Thanks!

  • Predrag Dubajic
    • Support

    Hi Riley with SOZO.DO,

    Could you provide us with cPanel or FTP login details so we can check the logs and try applying some tweaks to backup process on your site?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    NOTE: Don’t change selected topic in the dropdown, just leave it at “I have a different question”.

    Subject: “Attn: Predrag Dubajic

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,


  • Predrag Dubajic
    • Support

    Hi Riley,

    I have tried applying some Snapshot tweaks to try lowering backups speed and number of files processed at once in order to reduce server load but all of them still caused your server I/O to hit the limit and that’s when the backup process is terminated as it doesn’t have available resources to continue with the process.

    I will need to forward this to our developers so they can have a closer look and see if something can be done to overcome those limitations on your server.

    Please note that developer response might be slower than usual staff response, so we appreciate your patience on this.

    Best regards,


  • Konstantinos Xenos
    • Rubber Duck Debugger

    Hey Riley with SOZO.DO ,

    I’ve taken a look at the server and tried various configurations for Snapshot as well but it seems that as Predrag previously mentioned the system hits I/O limits really fast which is most likely breaking the backup process as well as resulting in the whole zip process being slow as well.

    Is there a possibility to ask your hosting provider to raise the limit ( I’d suggest double it if possible even ) so we can re-test after?

    We’re always improving Snapshot on use as low resources as possible but there isn’t an “easy” or standard fix that I could apply on your end as it mostly depends on the hosting system itself and it’s limitations.

    Please inform me if you’ve contacted your hosting provider or if I can help in any other way in the meantime.



  • Riley with SOZO.DO
    • Webprenuer

    Hello and thank you for your help! Sorry we’ve been super delayed in responding. Just to update where we’re at on this:

    We have contacted the host to see if we can increase I/O limits. We’re awaiting their feedback.

    In the meantime, things have changed a little bit… It looks like when you made tweaks, whatever those tweaks were, Snapshot now completes both snapshots and full backups on our server. However, it only completes them and stores them on our servers.

    It never backs them up to either the HUB or our alternate location, Google Drive.

    How come that’s happening? It can finish the backup, but then not an upload to the other places? That seems strange.

    Additionally, because of this, these backup files are never removed from our server. This is causing a major issue because every few weeks our storage limit is maxed out with these massive backups files. So we’re being forced to log in and manually delete these via FTP every week or two. Not an ideal setup.

    Please let me know your thoughts. Thanks!

  • Adam Czajczyk
    • Support Gorilla

    Hi Riley with SOZO.DO

    It’s great to hear that backups are being made now!

    There’s been Snapshot update since the our last post here (that could help) but also it’s possible that something was actually changed on server that helped.

    The “Snapshot tweaks” might not have much to do here because most of them are related to Managed Backups and from what I can see you only got snapshots (as in “Snapshot -> Snapshots”:wink: set up while Managed Backups are not enabled. Unless I”m missing something…?

    Still though, it seems it’s working fine indeed so that’s a great news.

    As for upload.

    Please note that “snaphosts” are never uploaded to The Hub – they are stored locally and can, additionally, be pushed to external destination of choice (such as your Google Drive).

    “Managed Backups” on the other hand would automatically be pushed to The Hub instead.

    Getting back to “Google Drive” then. I checked the site and there’s this error showing up in debug.log:

    Error: Could not connect to Google Drive: Error: Google_0814_Auth_Exception: Error refreshing the OAuth2 token, message: '{
    "error": "invalid_grant",
    "error_description": "Bad Request"

    This means that when Snapshot sent auth reqest to Google API, Google simply “denied” authorization. There might be multiple reasons for this but there’s a good chance that it’s one of these:

    – either no auth attempts were made to Google Drive API (earlier, before Snapshot started to work again) for at least 6 months

    – or you have change/updated your Google password meanwhile

    – or you have, for some reason (maybe even unknowingly) “de-authorized” the app

    In all these cases, it should simply suffice to “re-authorize” Snapshot and to do this simply go to “Snapshot -> Destinations”, enter Google Drive configuration there and use “RE-AUTHORIZE” button there. Please note: I can’t do it for you and you should be logged in to relevant Google Account while doing this.

    That should re-grant necessary credentials to the app and re-create auth token, thus solving the issue.

    If that doesn’t help, there are also other possible options (such as e.g. some changes made in app configuration in Google Developers console or similar) but let’s start with above. Would you give it a try please and let me know about results, please?

    Best regards,


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.