Backups think its with my server but don't know what and what to tell the hosting company

Think its with all the sites?

  • Predrag Dubajic
    • Support

    Hi Geeky Designs,

    Can you give us some more information about the backup issues you are having, are you seeing any specific errors on your site or in your logs?

    Are you using Snapshot plugin for your backups or something else?

    Usually, the case is that the server resources are exhausted during the process so what you can ask your host is to check the logs during the backup process and see if any of the server limits are being hit at that time and ask them if they can increase those for you.

    Best regards,

    Predrag

  • Adam Czajczyk
    • Support Gorilla

    Hello Geeky Designs

    they have changed the max to 600

    I assume you’re referring to “max_execution_time” PHP option, right?

    That’s sometimes an issue but the “resources” that Predrag mentioned usually apply to things like I/O limits (I/O stands for input/output and basically means the speed of file read/write operations allowed). But there might also be some other issues involved.

    Do you have any other additional backup plugins installed on site? Does running manage backup results only in error on Managed Backup page or the site also goes down?

    I would also like to take a closer look so could you please, for the start, enable support access to the site for me so I could do some initial testing? To enable support access please go to the “WPMU DEV -> Support -> Support Access” page in your site’s back-end and click on “Grant support access” button there.

    Let me know here, please, once it’s done as otherwise I won’t be automatically notified of that fact.

    Best regards,

    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello Geeky Designs

    I checked the site and tried to run managed backup on it. After around 45% it did break with “Site is experiencing technical difficulties” message and the entire site/server going down.

    That actually confirms the resources issues. It will need a bit more testing to see if we can overcome it or if it would need some “resource improvements” on host’s site. In this case, I’ll need a direct access to the site/server so would you please provide me with it?

    Note: Don’t leave your login details in this ticket.

    Instead, you can send me your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Adam Czajczyk

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – FTP credentials (host/username/password)

    – cPanel credentials (host/username/password)

    – Folder path to site in question

    – Link back to this thread for reference

    – Any other relevant urls/info

    Best regards,

    Adam

  • Geeky Designs
    • WPMU DEV Initiate

    Hi there, I have done all the above and ended up speaking to my hosting company and they have replied with saying send us the settings you need and we will change for you ? so I am not sure if you have any idea of what i can say to them ?

    Ta

    Dan

  • Adam Czajczyk
    • Support Gorilla

    Hello Geeky Designs

    I see that what Predrag suggested, apart from full conflict test, was asking host if there’s anything that could possibly be blocking outgoing connections.

    If they are asking about “settings” that’s a bit too “general” because there’s a lot of aspects that could potentially affect connections. They should be able to check server logs and find out whether anything is interfering or not.

    Having said that, if I am about to suggest what they should check, that’d be a couple of things:

    – none of these IPs should be blocked or limited in any way (it’d be best to whitelist them everywhere where possible – all the possible firewall/security tools; anything that might be related to rate limiting and so on)

    66.135.60.59
    66.135.49.214
    66.135.60.64
    165.227.66.214
    192.241.140.159
    104.236.132.222
    192.241.148.185

    – if there are any tools/rules applied on server that are e.g. limiting outgoing connections/requests they should be lifted for these IPs; it might also be good to white-list wpmudev.org domain and all it’s possible (wild-card) sub-domains for any incoming/outgoing traffic

    I’ve also consulted it with one of our developers and there’s one more thing worth trying. We’re using AWS and their “Multipart Upload” to upload backups to The Hub. The backup file is split to chunks that are sequentially uploaded and these chunks, by default, are of 50M of size. This, apparently, causes upload issues on some servers so it’s worth trying with smaller ones.

    The smaller one allowed by AWS is 5MB and it can be set by adding a small code snippet to the site:

    <?php
    function snapshot_custom_size_increment() {
    return 5 * 1024 * 1024;
    }

    add_filter( 'snapshot_model_transfer_part_size_increment', 'snapshot_custom_size_increment' );

    It should be added as MU plugin (“must use” plugin) and to do this:

    – create an empty file with .php extension (e.g. “smaller-snapshot-backup-chunks.php”:wink:

    – copy and paste the code from above into that file (using some “clean text”/code editor such as Notepad++, Sublime, Atom or similar)

    – save the file and upload it (using FTP or cPanel’s “File Manager or similar tool) to the

    /wp-content/mu-plugins

    folder in your site’s WP install. If there’s no “mu-plugins” folder directly in “wp-content”, just create empty one first.

    Once it’s done try re-uploading the backup and/or creating new one and see if it works.

    Best regards,

    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.