Batch Create - no link to run the queue - persistent problem

I have not been able to get this plug-in to work since upgrading to 3.1 or 3.2 (wouldn't work in either) from 3.0.x. It has run in the 3.0.x.

So, ever since the network admin has been on its own dashboard page.

I am using the latest version.

I create the file (either a csv, an xls, just writing over *your* sample xls, nothing works.)

This line: "Note: There are # items (blogs/users) waiting to be processed. Click here to process the queue. If there is a problem, you can clear the queue by clicking here."
NEVER appears!

It's simply not being written/shown so there is no way to process this.
All I can do is: Clear the log file

I have read other posts about this here but have yet to see any solution.
LAMP server, php-cgi.

HAS run before, this is WP/plug-in related, not server related.

I also have your 'New Blog Templates' and 'Add New Users' plug-ins installed. Would these cause conflict?

  • elramsay

    Hello,

    No, nothing is created.

    I cannot simply deactivate all my plug-ins for this. This is a live site, with users. I *have* gone through all the plug-ins recently and disabled anything not WP3.2 compatible. I hoped that would fix the issue I had with this plug-in too. I have de-installed and re-installed Batch-Create and tried again, since I posted this earlier this day.

    We are using the BP Fun template for the main BP blog.

    These are our network active plug-ins:
    Add New Users
    Batch Create
    Blogger Importer
    BP-Album+
    BP Group Documents
    BP Group Management
    BuddyPress
    Buddypress Profile Widget for Blogs
    Categories to Tags Converter Importer
    jQuery Lightbox For Native Galleries
    LiveJournal Importer
    Movable Type and TypePad Importer
    New Blog Templates
    NextGEN Gallery
    RSS Importer
    Sidebar Login
    Sitewide Privacy Options for WordPress Multisite
    Wickett Twitter Widget
    WordPress Hashcash
    WordPress Importer
    WP-SpamFree
    WPaudio
    WPMS Mobile Edition
    WPMU Custom CSS
    WPMU DEV Update Notifications

    If you think one of these may be problematic, I can focus on it. However, earlier versions of Batch Create have worked along these installed plug-ins.

    I know Batch-Create is very particular about its file format, I used your test.xls file, simply changed the name and added 1 line for one user (Today, I am just trying 1 test user, since this keeps failing).
    I am using a Mac, Excel 2008

    I also tried using Text Wrangler to create a csv file too, following the strict instructions from your earlier version. I am familiar with creating csv files.

    I can't use sites like pastebin to post files of confidential user information, I don't see how it would work anyway, since it's for snippets of text, not files. If there is a way to share the file with WPMU without making it public, I will do that.

    Is there perhaps cruft in the database from failed attempts of this I should look for?

    Is it a Mac OS issue perhaps? Again, this *did* work before WP 3.1

  • Philip John

    Hiya,

    Okay, well if you can test deactivating all plugins that would be a good place to start as we need to rule out a conflict - even a new one. Besides, I'd recommend testing out all new plugins on a development install before moving to a live site.

    Can you double check your settings in Excel and make sure that the CSV is definitely saved using comma-separated values and not tab-separated. We've had members issues caused by that before.

    Check whether quotes are included too.

    Phil

  • elramsay

    I have spent a lot of time cleaning up the plug-ins already and HAVE deleted problematic ones. These ones are pretty standard, have worked before with Batch Create. Simply requesting users de-activate all their plug-ins any time there's trouble isn't that helpful in live environment. I hope your plug-ins are tested in real world situations.

    I have had this working at my live site. Your upgrade or the WP upgrade has resulted in the script no longer running properly. The only way I can de-activate all my plug-ins is to wait until my site is less active.

    But, I believe the issue must be with the file itself.
    Is it a Mac issue?

    When I export this to csv from Excel it puts quotes around the header line text and commas between the variables.

    When I export from Text Wrangler I saved as a CRLF, which the earlier version of Batch Create needed to work properly. No header, comma delineated. Is .csv ok? Is it still looking for a .txt file?

    You didn't answer my questions about whether the database might need cleaning up after multiple unsuccessful attempts at this? or whether there might be issues with Mac OS Excel 2008 (saving as Excel 97-2004)? This *is* a newer version of Excel than I used before.

    Attached is a xls file to create 1 fake account. This is the same as what I tried except this user is all fake info, the one I tested was real user info. But, will it run?

  • Philip John

    These ones are pretty standard, have worked before with Batch Create

    There are very few "standards" when it comes to plugin development and more often than not issues do come down to plugin conflicts. I can help you but until you can de-activate everything I can't be sure I'm helping in the right way.

    Simply requesting users de-activate all their plug-ins any time there's trouble isn't that helpful in live environment

    Hence why you should be testing in a development environment first. WP plugins are coded in such a way that conflicts are quite commonplace.

    But, I believe the issue must be with the file itself.

    This latest release has been out nearly a month and we've had no issues despite close to 250 downloads so I doubt that's the case. We have however seen issues with TSV vs CSV.

    No header, comma delineated. Is .csv ok? Is it still looking for a .txt file?

    Yes CSV is supported. The extension shouldn't matter, but it's best to use .csv.

    You didn't answer my questions about whether the database might need cleaning up after multiple unsuccessful attempts at this?

    If you're trying to import anything that's already present, yes it will fail and you'll need to flush those users/sites out before you try again.

    You can e-mail the file to contact@wpmudev.org - make sure you include a link to this thread.

    Phil

  • Philip John

    Hiya!

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Cheers,
    Phil

  • elramsay

    No, this plug-in is still not running and not useful to me. The most recent upgrade seemed to at least read the uploaded file but it still wont run and it fails if there is a user on the list already in the database. Since I was hoping to use this to process users from lists supplied by my school, repeat names will be inevitable.

    A more disturbing issue is that we discovered that this plug-in, while seemingly doing nothing, left a directory called batch-create and a document called bach-create.log in EVERY blog files directory in my multi-user environment. Blogs NOT created with your plug-in. I am not happy about this.

    I am using a simple, free create user script instead for my current needs and have given up on this working.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.