Batch Create not working

I installed the Batch Create plugin on my site as I have to create a ton of blogs. I have an excel spreadsheet set up for each state with all the cities and towns for that state listed on the spreadsheet.
I am using the template xl spreadsheet provided with the plugin.
The plugin was working splendidly for the first several spreadsheets and now it is not. I have uploaded the last two spreadsheets and gotten it queued up and when I press process queue it starts and stops after processing only one item on the spreadsheet. This really sucks as I have to sit there and continue to press the process button for each one and when you have a spreadsheet with 400+ items I'm not saving any time hence the reason for using the plugin to begin with.
I should not have to try processing smaller amounts because it has processed 500+ before.

  • ValBloomberg

    The blogs are created just fine but I have to keep hitting the queue because it is only processing one blog at a time...it also appears to be trying to recreate blogs that have already been created.
    Here is a sample of the log file:

    2011-11-10 21:01:09 [debug] - --- Starting queue item processing ---
    Blog name: [wellingtonfl]
    User name: [Valerie]
    2011-11-10 21:01:09 [debug] - User Valerie already exists (3)
    2011-11-10 21:01:09 [debug] - Blog name not empty (wellingtonfl)
    2011-11-10 21:01:09 [debug] - Blog (wellingtonfl) already exists (2102), user can be added
    2011-11-10 21:01:10 [info] - User Valerie successfully added to blog wellingtonfl.theus.co/
    2011-11-10 21:01:10 [debug] - --- Queue item processing finished ---

    2011-11-10 21:01:12 [debug] - --- Starting queue item processing ---
    Blog name: [weekiwacheefl]
    User name: [Valerie]
    2011-11-10 21:01:13 [debug] - User Valerie already exists (3)
    2011-11-10 21:01:13 [debug] - Blog name not empty (weekiwacheefl)
    2011-11-10 21:01:13 [debug] - Blog (weekiwacheefl) does NOT already exist
    2011-11-10 21:01:13 [debug] - Starting new blog creation
    2011-11-10 21:01:13 [debug] - New user is administrator
    2011-11-10 21:01:13 [debug] - Attempting to create a new blog with this data:
    Domain: [weekiwacheefl.theus.co]
    Path: [/]
    Title: [Weeki Wachee Florida]
    Admin user ID: [3]
    On site: [1]
    2011-11-10 21:01:15 [debug] - Blog successfully created, sending email
    2011-11-10 21:01:29 [debug] - --- Starting queue item processing ---
    Blog name: [weekiwacheefl]
    User name: [Valerie]
    2011-11-10 21:01:29 [debug] - User Valerie already exists (3)
    2011-11-10 21:01:29 [debug] - Blog name not empty (weekiwacheefl)
    2011-11-10 21:01:30 [debug] - Blog (weekiwacheefl) already exists (2103), user can be added
    2011-11-10 21:01:30 [info] - User Valerie successfully added to blog weekiwacheefl.theus.co/
    2011-11-10 21:01:30 [debug] - --- Queue item processing finished ---

    2011-11-10 21:01:32 [debug] - --- Starting queue item processing ---
    Blog name: [welakafl]
    User name: [Valerie]
    2011-11-10 21:01:33 [debug] - User Valerie already exists (3)
    2011-11-10 21:01:33 [debug] - Blog name not empty (welakafl)
    2011-11-10 21:01:33 [debug] - Blog (welakafl) does NOT already exist
    2011-11-10 21:01:33 [debug] - Starting new blog creation
    2011-11-10 21:01:33 [debug] - New user is administrator
    2011-11-10 21:01:33 [debug] - Attempting to create a new blog with this data:
    Domain: [welakafl.theus.co]
    Path: [/]
    Title: [Welaka Florida]
    Admin user ID: [3]
    On site: [1]
    2011-11-10 21:01:35 [debug] - Blog successfully created, sending email
    2011-11-10 21:02:53 [debug] - --- Starting queue item processing ---
    Blog name: [welakafl]
    User name: [Valerie]
    2011-11-10 21:02:53 [debug] - User Valerie already exists (3)
    2011-11-10 21:02:53 [debug] - Blog name not empty (welakafl)
    2011-11-10 21:02:53 [debug] - Blog (welakafl) already exists (2104), user can be added
    2011-11-10 21:02:54 [info] - User Valerie successfully added to blog welakafl.theus.co/
    2011-11-10 21:02:54 [debug] - --- Queue item processing finished ---

  • topranking

    Hi, I have viewed the screen shots of the batch create upload, after I put in the require info indicated
    in the instructions, I'm getting this error message:
    2011-11-13 04:48:02 [debug] - --- Starting queue item processing ---
    Blog name: [wheretoprintmanufacturercoupons]
    User name: []
    2011-11-13 04:48:02 [debug] - User does NOT exists. Creating a new user
    2011-11-13 04:48:02 [info] - There was an error creating a user

    I have tried putting in the default username, and userpass and tried it with my real user and p/w
    and I still am getting the same results.

    Has anyone in this forum has had this problem? Any suggestions as to what my be the issue?

  • Vladislav

    Hi,

    I have been trying to reproduce the issue you're getting, and I managed to get something pretty similar with the simulated server timeouts. Those can happen, especially on a large, busy site (or a busy blog/user registration procedure). The latest plugin version (v1.2.2, just released) is trying to enforce a longer timeout, to prevent such issues from happening. Can you please upgrade and see if it helps?

  • Philip John

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this thread as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and, as always, for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!
    Phil

  • aecnu

    Greetings IICS,

    Thank you for this great question and a significant item to bring up.

    I found this ticket in the back of the ticket system while doing some housekeeping tonight.

    If you are still having this issue you should open a ticket of your own feeling free to copy and paste and relevant information form this ticket to the new one.

    Luckily I stumbled across this ticket because not only did you reply to a ticket that was created by a member that is inactive but also the staff that was monitoring this ticket is no longer with WPMU Dev.

    Thank you for your understanding and for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.