Batch create plugin doesn't seem to recognize and assign users to already created blogs.

Using the batch create plugin I have no issues creating new blogs/users etc. However when attempting to assign new or existing users to an existing blog the upload seems to lose the blog name. For instance, the existing blog url is http://blogs.henrico.k12.va.us/well. I upload a csv that consists of- well,null,hcps-babcockej,null,hcps-babcockej@blogs.henrico.co,subscriber - as per the example item on line 4.

The result is the following error log -

2013-09-17 02:32:12 [debug] - --- Starting queue item processing ---
Blog name: [well]
User name: [hcps-babcockej]
2013-09-17 02:32:12 [debug] - User hcps-babcockej already exists (ID: 34376)
2013-09-17 02:32:12 [debug] - Blog (blogs.henrico.k12.va.us) does NOT exist yet
2013-09-17 02:32:12 [debug] - There was no explicitly requested blogs; adding user to main blog
2013-09-17 02:32:12 [debug] - --- Queue item processing finished ---

It appears to look for blogs.henrico.k12.va.us rather than the blogs.henrico.k12.va.us/well - although both blogs exist.

I've tried this with a few different variations, different blogs etc. and run into the same error. New vs existing users doesn't seem to matter. Various user rights, etc.

Thanks.