Big problem with multisite and content that is only shown when logged in

Hi guys again i have a very big problem with my multiste installation and the content that is only shown when i am logged in! Have a look at this site: http://bgt.oestreich.net/
the header and the second language flag is only loading when i am logged in, when you put a /en/ behind the adress you can see the englisch translation. I had the same problem a few days ago when i changed the domain mapping. Is there something i have to look at or is something wrong with my installation? Please help me. When you are logged and then log out in some times the flag will show up but it seems only in the cache on other browsers and machines it will not show! Please have alook at the domain mapping or the settings of the webiste. i have granted webiste access over the wpmu dev tool

  • Rupok
    • Support Ninja

    Hi hannes

    Hope you had a wonderful day.

    I had the same problem a few days ago when i changed the domain mapping. Is there something i have to look at or is something wrong with my installation?

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Have a nice day. Cheers!

  • hannes
    • Site Builder, Child of Zeus

    Anybody out there? i think the problem is caused by domain mapping! When i didn`t use domain mapping everything is fine when i use domain mapping the flags will not shown. can somebody have a look at it - are my permalink settings ok? you can log in via wmpu dev dashboard and you can also delete the mapping of the site /bgt an reactivate it it is no a live site!

  • Kasia Swiderska
    • Support nomad

    Hello hannes,

    There is problem with support access - I can see that is enabled, but when I try to use it redirects me to login page.
    Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    kind regards,
    Kasia

  • Rupok
    • Support Ninja

    Hi hannes

    Hope you had a wonderful day.

    Thanks for sending details. I tried to investigate the issue, but seems like your site is highly cached. I changed default language from German to English from WPML settings, but the site homepage was still showing german. And only the homepage is not showing English language flag. Even your 404 error page is showing two flags fine: http://bgt.oestreich.net/404

    Can you please give us details about what type of caching you are using? And can you please confirm this is not being caused by any caching plugin? Is this a live site? Can I turn off Domain Mapping to see the issue live and try to fix? I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!

  • hannes
    • Site Builder, Child of Zeus

    Hi Rupok,

    we only have one domain that is used in domain mapping active, but i think it is okay, when you turn it down for a while to test the settings. i also tested it and the problem is gone when i deinstall domain mapping tool from wpmudev! We use wp rocket to cache the site, you can completely deinstall it when this helps! i tested it again an when i turn down domain mapping everything works at it should :slight_frown: if you need ftp account etc. please tell me, at the moment this is a big problem for me! thanks for your help

  • hannes
    • Site Builder, Child of Zeus

    Hi Rupok, i deinstalled the wp rocket plugin and cleaned up the database after this it seems to work, can you also test it? I think the best way no is to contact the wp rocket team to help in this constellation! thnak you very much for your help!

  • Kasia Swiderska
    • Support nomad

    Hello hannes,

    I've tested you site while logged out and logged in and on both there are two flags, I can switch between two languages without problem and from what I see this works on the mapped domain so mapping is enabled.

    On thing I noticed that you will need to adjust menu in English version because now it has links to the section of your website without the language code so it switches to the German. In English version you would need to add it like that /en/#contact so it will not switch back to.

    Let us know what the WP Rocket guys will tell about this issue.

    kind regards,
    Kasia

  • hannes
    • Site Builder, Child of Zeus

    hello again, i tlaked with the guys from wp rocket and the problem was that i installed wp rocket network wide and not activated it site by site. After this it seems that there is no more problem :slight_smile: to the team here, thanks for the support :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.