Blank Checkout Page (No Grid/Options)

Hello,

I've tried to tinker with my settings and checked the other postings for an indication of what I am doing wrong. I think I'm running into a theme issue here, but I can't get the Checkout page to display correctly, it just appears as a blank page titled 'Pro Sites'. Please check it out here http://www.urbanruckus.com

Test Account Credentials:
L: testacct1
P: testuser

Thanks!

  • 3SixtyEvolve
    • New Recruit

    Hi ebreuers

    Welcome to the WPMU DEV Community and thank you for being a member.

    I had a look at your website - logged in and found the blank page for Pro Sites. I also tried to reproduce the error in my own development environment, but wasn't able to.

    So, I would like to suggest that you switch your theme on the Super Admin back to the basic WordPress Twenty Eleven Theme and see if you still have the same issue when logging into this test account. If so, then please deactivate all plugins, except the Pro Sites Plugin and activate the other plugins one by one to see whether one of these plugins is causing a conflict with the Pro Sites Plugin.

    If the problem still persist, please let me know so we can have a closer look at your WordPress installation and setup for the Pro Sites.

    I look forward to hearing from you.

    Have a good day!

    GinaB

  • ebreuers
    • Site Builder, Child of Zeus

    Hi Gina,

    After switching the theme to Twenty Eleven, my pricing page showed up properly... Now I'm stuck because I've spent a considerable amount of time and money on the Dynamix theme and it's custom skin. Is there any way we can solve this for the Dynamix theme?

    Regards,
    Eric

  • 3SixtyEvolve
    • New Recruit

    Hi Eric

    Thank you for your latest post. I will make sure to pass your request on to the Developer of Pro Sites. He might be able to provide some suggestions on how to make the theme work for you when using Pro Sites.

    I think we might need to have a look at the theme files, but I will leave it to the Developer, since I'm not too sure which files we would need to see.

    Thank you for your patience. We will revert back to you at the earliest.

    Gina

  • ebreuers
    • Site Builder, Child of Zeus

    Hey Gina and Aaron,

    Thanks for the replies! I was beginning to worry about this one getting resolved, I absolutely love this theme, but I'm noticing issues with the Pro Sites plugin as well as Marketpress. I'll post the page.php info below. Should I start a new thread in the Marketpress forum?

    Best Regards!

    Page.php:

    <?php
    /**
     * @package WordPress
     * @subpackage Default_Theme
     */
    
    ?>
    
    <?php get_header();
    if(!is_search()) {
    require CWZ_FILES ."/inc/page-constants.php"; // Get constants
    } ?>
    
    <?php if($DYN_hidecontent!="yes") { ?>
    
    <?php if($DYN_layout!="layout_four" && $DYN_layout!="layout_five") { 
    
    	get_sidebar(); 
    
    } ?>
    
        <div class="mid-wrap <?php 
    
    		if($DYN_layout=="layout_one") { ?> left out-full  <?php } 
    
    		elseif($DYN_layout=="layout_two") { ?> right out-threequarter  <?php }
    
    		elseif($DYN_layout=="layout_three") { ?> right out-half  <?php }
    
    		elseif($DYN_layout=="layout_four") { ?> left out-threequarter  <?php }
    
    		elseif($DYN_layout=="layout_five") { ?> left out-half  <?php }
    
    		elseif($DYN_layout=="layout_six") { ?> left out-half  <?php }
    
    		else { ?> left out-threequarter  <?php }
    
    	?>">
    
                	<div id="content">
                    	<div class="post" id="post-<?php the_ID(); ?>"><!-- post -->
    
    		<?php if($DYN_textresize=="yes") { ?>
                                <div class="textresize">
    
    <ul>
                                        <li class="resize-sml"><img src="<?php bloginfo("template_url"); ?>/images/blank.gif" width="16" height="22"  alt="Decrease" class="decreaseFont" />
                                        <li class="resize-lrg"><img src="<?php bloginfo("template_url"); ?>/images/blank.gif" width="20" height="22"  alt="Increase" class="increaseFont" />
                                    </ul>
                                </div><!-- /textresizer -->
            <?php } ?>
    		<?php if($DYN_socialicons=="yes") {
                require_once CWZ_FILES .'/inc/social-icons.php';
            } ?>
                         <?php if($DYN_postdate!="" && $DYN_authorname!="" && $DYN_pagesubtitle!="" && $DYN_pagetitle!="" || $DYN_pagetitle !="BLANK") { ?>
                                <div class="post-titles"><!-- post-titles -->
                                   <?php if($DYN_pagetitle) { ?>
                                    		<?php if($DYN_pagetitle != "BLANK") { ?>
    										<h1><?php $DYN_pagetitle = htmlspecialchars($DYN_pagetitle); echo do_shortcode($DYN_pagetitle); ?></h1>
                                            <?php } ?>
    								<?php } else { ?>
                                    		<?php if($DYN_pagetitle != "BLANK") { ?>
    										<h1><?php the_title(); ?></h1>
                                            <?php } ?>
    								<?php } ?>
                                    <?php if($DYN_pagesubtitle) { ?>
                                            <h2><?php $DYN_pagesubtitle = htmlspecialchars($DYN_pagesubtitle); echo do_shortcode($DYN_pagesubtitle);  ?></h2>
                                            <?php } ?>
                                    <?php if($DYN_postdate || $DYN_authorname) { ?>
                                     <div class="hozbreak nospace"> </div>
                                        <p class="post-date">
                                                <?php if($DYN_postdate) { ?>
                                                <small><?php the_time('F jS  Y'); ?></small><span class="break"> </span>
                                                <?php } ?>
                                                <?php if($DYN_authorname) { ?>
                                                <small>By <span class="author"><?php echo the_author_firstname(); ?> <?php echo the_author_lastname(); ?></span></small>
                                                <?php } ?>
                                        </p>
                                     <div class="hozbreak nospace"> </div>
    								<?php } ?>
                                </div><!-- /post-titles -->
    							<div class="clear"></div>
                                <?php } ?>
                                <div class="entry"><!-- entry -->
                                    <?php the_content('<p class="serif">Read the rest of this page »</p>'); ?>
    
                                    <?php wp_link_pages(array('before' => '<ul class="paging"><li class="pages">'.__('Pages', 'DynamiX' ).': ', 'after' => '','link_before'=> '<li class="pagebutton">',  'next_or_number' => 'number', 'link_after'=> '',)); ?>
                                </div><!-- /entry -->
                         </div><!-- /post -->
    
                        	<?php edit_post_link(__('Edit this entry.', 'DynamiX' ), '<p>', '</p>'); ?>
    
    				<?php // comments_template(); // Enable this line for comments on pages ?> 
    
                    </div><!-- /content -->
                    <div class="clear"></div>
    
    	</div><!-- /mid-wrap -->
    
    <?php get_sidebar(); ?>
    
    <?php } // Hide Content *END* ?>
    
    <?php get_footer(); ?>
  • Aaron
    • CTO

    As i suspected they got lazy and didn't use a loop as they should. Nevery fear though, it's simple to add.
    http://codex.wordpress.org/The_Loop
    http://codex.wordpress.org/The_Loop_in_Action

    Change this part to:

    <div id="content">
    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
                    	<div class="post" id="post-<?php the_ID(); ?>"><!-- post -->

    then near the end

    <?php endwhile; else: ?>
    <p><?php _e('Sorry, no page matched your criteria.'); ?></p>
    <?php endif; ?>
    </div><!-- /content -->
     <div class="clear"></div>
  • ebreuers
    • Site Builder, Child of Zeus

    Aaron,

    YOU ARE THE MAN! Thank you so much, it worked like a charm!

    Any ideas on the Marketpress issue? Or do you think that was related?
    A million more 'thank yous'

    -Eric
    (I'm a newbie now, but I'll be completing my technical web design course by the end of October and hopefully I'll be on the more helpful end here soon!)

  • 3SixtyEvolve
    • New Recruit

    @Aaron
    Great solution! In my favorites folder for sure :slight_smile:

    Eric @ebreuers
    Glad you got sorted. Let us know if you need any further assistance and thank you for your presence on the Community Forums. Appreciate your constant inputs :slight_smile:

    Gina

  • ebreuers
    • Site Builder, Child of Zeus

    @GinaB: Thanks for bringing this to Aaron's attention, that was quick and effective!

    @Aaron: I did just that :slight_smile: I hope he cleans it up in the next release.

    Thanks again guys, this community is amazing!

    Regards,
    Eric

  • LDI IT
    • Site Builder

    Hello,

    I believe I have a similar if not the same issue as ebreuers. However I'm a little lost as to where I could place the code Aaron suggested, and into which file.

    index.php / page.php

    I have attached both for you to review. Any help on this would be fantastic.

    I thank you for your time and help in advance.

  • LDI IT
    • Site Builder

    Page.php text below:

    <?php
    /**
    * @package WordPress
    * @subpackage ThemeWoot
    * @author ThemeWoot Team
    *
    * This source file is subject to the GNU GENERAL PUBLIC LICENSE (GPL 3.0)
    * that is bundled with this package in the file LICENSE.txt.
    * It is also available through the world-wide-web at this URL:
    * http://www.gnu.org/licenses/gpl-3.0.txt
    */
    $layout=themewoot_helper( 'meta', 'layout' );
    ?>
    <?php get_header(); ?>
    <div id="post-<?php the_ID(); ?>" <?php post_class(); ?>>
    <div class="site-content container pt pb clearfix">

    <?php if($layout=='left') { get_sidebar(); } ?>

    <article id="primary-wrapper" <?php themewoot_layout_class($layout); ?>>
    <div class="content-area inner">
    <?php if (have_posts()) : the_post(); ?>
    <?php if(get_the_content()) : ?>
    <div class="post-content entry-text">
    <?php the_content(); ?>
    </div>
    <?php wp_link_pages( array( 'before' => '<div class="page-link">' . esc_attr__( 'Pages:', 'Twoot' ), 'after' => '</div>' ) ); ?>
    <?php endif; ?>
    <?php endif; ?>
    </div>
    </article>
    <!--end #primary-->

    <?php if($layout=='right') { get_sidebar(); } ?>

    </div>
    </div>
    <!--end #content-->
    <?php get_footer(); ?>

  • Patrick
    • Support Monkey

    Hi there @ADET

    As this ticket is more than 2 years old (notwithstanding the posts by Nicholas), and Pro Sites has evolved greatly since then, I'm closing it to further replies to prevent duplication of efforts and the confusion that can result.

    For all others who happen upon this thread, please create a new support ticket for your own issue.

    Thanks everyone for your understanding!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.