Blank Screen

Hi,
I'm getting blank screen issue. So weird? I tried to deactive all plugins and problem still going.

Thanks.

  • aecnu
    • WP Unicorn

    Greetings Mustafa,

    This is a tough one because there can be many possibilities.

    The first thing I would do is check the wp-config.php file to see if there are any blanks or carriage returns.

    Here are two examples, one of a working wp-config.php file and second a non working file:

    Working:

    — File Starts —
        <?php
        // ** MySQL settings ** //
        define(‘DB_NAME’, ‘putyourdbnamehere’); // The name of the database
        define(‘DB_USER’, ‘usernamehere’); // Your MySQL username
        define(‘DB_PASSWORD’, ‘yourpasswordhere’); // …and password
        define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
        define(‘DB_CHARSET’, ‘utf8?);
        define(‘DB_COLLATE’, ”);
    
        // Change SECRET_KEY to a unique phrase. You won’t have to remember it later,
        // so make it long and complicated. You can visit http://api.wordpress.org/secret-key/1.0/
        // to get a secret key generated for you, or just make something up.
        define(‘SECRET_KEY’, ‘put your unique phrase here’); // Change this to a unique phrase.
    
        // You can have multiple installations in one database if you give each a unique prefix
        $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!
    
        // Change this to localize WordPress. A corresponding MO file for the
        // chosen language must be installed to wp-content/languages.
        // For example, install de.mo to wp-content/languages and set WPLANG to ‘de’
        // to enable German language support.
        define (‘WPLANG’, ”);
    
        /* That’s all, stop editing! Happy blogging. */
    
        define(‘ABSPATH’, dirname(__FILE__).’/');
        require_once(ABSPATH.’wp-settings.php’);
        ?>
        — File Ends —

    Non Working:

    ` — File Starts —
    <?php
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘putyourdbnamehere’); // The name of the database
    define(‘DB_USER’, ‘usernamehere’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘yourpasswordhere’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    define(‘DB_CHARSET’, ‘utf8?);
    define(‘DB_COLLATE’, ”);

    // Change SECRET_KEY to a unique phrase. You won’t have to remember it later,
    // so make it long and complicated. You can visit http://api.wordpress.org/secret-key/1.0/
    // to get a secret key generated for you, or just make something up.
    define(‘SECRET_KEY’, ‘put your unique phrase here’); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = ‘wp_’; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to ‘de’
    // to enable German language support.
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    define(‘ABSPATH’, dirname(__FILE__).’/');
    require_once(ABSPATH.’wp-settings.php’);
    ?>

    — File Ends —`

    The difference between the two is the carriage return in the non working between the ?> and the — File Ends —. Unbelievable but true that this suttle thing can take out the whole network.

    Please advise if you find a space that should not be there in your wp-config.php file.

    Cheers, Joe

  • 3SixtyEvolve
    • New Recruit

    Hi Mustafa

    Just landed on this post by chance and wanted to pitch in since I had the same issue a few days back. I auto-updated a couple of themes and one of them actually caused the blank screen. Luckily I remembered which ones I auto-updated, so deleted those from the theme folder and problem was solved for me. I was still running on WordPress 3.2.2 when this happened. Upgraded after that and then re-installed the themes and no further blank screens.

    Hope you get this sorted.

    Gina

  • Mark
    • The Incredible Code Injector

    Have you tried increasing your memory limit? This has worked for me in the past with blank screen issues.

    From http://codex.wordpress.org/Editing_wp-config.php

    Increasing memory allocated to PHP

    This setting increases PHP Memory only for WordPress, not other applications. By default, WordPress will attempt to increase memory allocated to PHP to 32MB (code is at beginning of wp-settings.php), so the setting in wp-config.php should reflect something higher than 32MB.

    WordPress will automatically check if PHP has been allocated less memory than the entered value before utilizing this function. For example, if PHP has been allocated 64MB, there is no need to set this value to 64M as WordPress will automatically use all 64MB if need be.

    Please note, this setting may not work if your host does not allow for increasing the PHP memory limit--in that event, contact your host to increase the PHP memory limit. Also, note that many hosts set the PHP limit at 8MB.

    Increase PHP Memory to 64MB

    define('WP_MEMORY_LIMIT', '64M');

  • aecnu
    • WP Unicorn

    Greetings Mustafa,

    You tried redefining the memory limit where? in the php.ini file?

    If you in fact were redefining it in WordPress and it is not set to a higher limit in your php.ini file then it does not matter.

    If you do not have one already, I have attached a phpinfo.php file to check your php.ini file to see what the memory is indeed set at.

    Download, extract, upload to root of web site, call it up in your browser http://yourdomain.com/phpinfo.php and lets see what the following two settings are set at:

    memory_limit and max_execution_time

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Mustafa,

    Thank you for your feedback it is certainly appreciated.

    In my opinion the max execution time is way out of line being way too high, I would expect that 240 would be plenty i.e. max_execution_time: 240

    But the memory_limit: 128M is a bit low, there must be enough memory to process the entire dynamic script and ours is set to 512MB and we have not had a blank screen issue to date on anything.

    To show I practice what I preach: http://wpmu-hosting.org/phpinfo.php

    However, as we both know there are many possibilities to cause the white screen.

    You are only getting this with the Infinite SEO plugin try to pull up a sitemap?

    No other instance?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Mustafa,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.