Blank screen when trying to configure Smush pro

After using Smush pro seamlessly for a couple of days, i get a blank screen when clickin on settings: http://www.grootsneek.nl/wp-admin/upload.php?page=wp-smush-bulk. No way to configure anything. Could you help me?

  • wim

    I have followed your instructions. Same result. I had read in one of the request of another user that someone advised him to deactivate the cache programme. I'm using W3Total Cache and it appeared to be the conflicting plugin. I would be sad to loose my caching programme because it decreases the number of database requests enormously according to my service provider. There must be a way to prevent both plugins from conflicting with each other. Do you know how?

  • Sajid

    Hi @wim, hope you are well and had a great weekend :slight_smile:

    I tried to reproduce this issue on both sandbox sites (multisite and single installation). But could not replicate this issue. Object cache is enabled on my both sites.

    Can you mention the steps, so I can reproduce it on my testing sites? Also is there any other plugin installed or only these two are active.

    Cheers, Sajid

  • wim

    Hi Sajid,

    First of all I deactivated all my plug ins except Smush. Worked OK. After that I activated one by one my other plugins, in the meantime trying Smush. OK. Untill I reactivated W3TC. Blank screen. I toggled off all the caching options. Smush OK. Than toggled them on one by one. After each option I tried Smush. That went OK untill I came with the option Object cache. Blank screen. Deactivated Object cache - blank screen. etc.

  • Jose

    Hello there @wim,

    Hope you are doing great.

    I'd be glad to take a look directly into your site and try to spot the specific error if you can grant me WP admin and FTP access.

    Please send me the following information via contact form :

    - In the subject field add "Attn: Jose”
    - Link back to this thread
    - Include WP admin/network access
    - Include FTP host and credentials.

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Cheers,
    Jose

  • Jose

    Hi again Wim,

    I was able to spot and fix the issue.
    The problem was your max memory limit being reached when rendering the dashboard.
    I changed the limit from 256M to 512M by adding the following in your wp-config.php:
    define( 'WP_MAX_MEMORY_LIMIT' , '512M' );

    It is unusual that the dashboard requires more than 256M, so there might be some piece of code using more resources than the expected.
    I noticed also that your site is triggering the following warnings:

    Warning: mysql_connect(): Headers and client library minor version mismatch. Headers:50541 Library:50615 ...

    As far as I know, this may be caused by an outdated php-mysql driver.
    If this is a managed server, you should reach your hosting and ask them to fix it.
    If you are managing the server, you can try the following:

    sudo apt-get remove php5-mysql
    sudo apt-get install php5-mysqlnd

    The site is working fine, so you may want to ignore this issue. But I believe it may be related to the memory usage, and it will likely cause issues in the future.

    Hope this helps.

    Cheers,
    Jose

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.