Blog directory and privacy settings

Hi!
We've been playing with the blogs directory plugin for our school. I notice that it will list all of the blogs perfectly if a user is logged in. For unauthenticated (guest) users, no blogs appear.

We have the privacy settings for all blogs set to "I would like to block search engines, but allow normal visitors." (public flag in the blogs table is 0).

Seems to me, the plugin is looking for the public setting in the blogs table to be 1, while ours is set to 0. I've looked through the plugin and can see checks for spam, deleted and blog #1, but can't seem to find where the public flag is checked. I'm sure it's somewhere obvious - but can someone suggest where I should be looking? My assumption is I just need to change the select call to public = 0 from public = 1 .... if I could find it!

Thanks for the help,
Sheldon.

  • drmike

    Public set to 0, in addition to asking search engines not to index the blog, removes the blog from all sitewide listings. That's why you can't see it on the blog directory. (edit: Well, in theory. See below.)

    I was going to write this explanation about editing the plugin and removing the public check but from scanning the plugin, I don;t see any public check in the code. Even the count of the blogs that it pulls to keep track of the numbering isn;t doing the check.

    I;m wondering if there's a different issue.'

    Anything in your webserver's error logs?

    You did go in and choose the different options for this plugin, right?

    edit: Let's see if we can get the developer in here and figure this out for us. Ivan?

    While we're waiting, can we get a link to the output page, please? We may see the issue with it in front of us.

  • sbradshaw

    Thanks so much for your help!

    I'm glad to see that I'm not the only one who couldn't see an obvious flag! We had to change the recent-global-posts widget as well, changing the public=1 to public=0. I assumed this would be the same.

    I've attached 2 screenshots - 1 logged in and 1 not. When logged in, the directory works as expected. When I change a blogs privacy settings to allow indexing by the search engines, the directory also shows it when NOT logged in. This is the public = 1 flag, but damned if I can find where it is!

    The blogs are all openly viewable. We have public access - we just don't want them indexed!

    Any thoughts? I've been poking around a bit more today and can't find a thing!

    Cheers,
    Sheldon

  • Mason

    Hiya,

    From your screenshots, it looks like you're using BuddyPress. Are you using our Blog Directory plugin? It's not meant to be compatible with BuddyPress.

    Additionally, I think the blogs not displaying when set to private is a default BuddyPress action. You can overwrite this with a custom loop in your theme file or by modifying the function within BuddyPress.

    Check out bp_blogs_templates.php and blogs_loop.php in BuddyPress for examples of the functions you'll want to modify.

    Hope this helps!