Blog Directory on the front page

Hi,
I have a WP 3.0.1 MU with the template WP-NELO
I would like to show the directory of blogs on the home page ?
Do you have a idea how to do that ?
Thanks for your help.
Pierre-André

  • Mason
    • DEV MAN’s Sidekick

    Hiya Pierre-André!

    I would like to show the directory of blogs on the home page

    Sure, we can do that!

    Have you followed the Blog Directory instructions, installed the file into mu-plugins and created a page in WordPress called "Blogs"?

    If you have the final step is to go to Settings>Reading and change the "Front page displays" to Static Page and then select "Blogs" from the drop down menu for Home Page.

    Save your settings and you should be good to go! :smiley:

    Let us know if you need anything else. Thanks!

  • Mason
    • DEV MAN’s Sidekick

    Hiya!

    Sorry that didn't work for ya. I just ran through a test of it and it is working for me on WP 3.0.1 with multisite.

    Are you seeing any errors? What does the homepage look like when you make the changes I suggested?

    A bit more info and we'll figure this out. :smiley: Let us know.

  • inetis
    • WPMU DEV Initiate

    Hi,
    It was a problem with an other plugin. Now I can show the directory on the front page. Only one thing is not working is the pagination.

    The base address is : http://mysubdomain.mywesite.ch
    When I press "Next", it try to go to http://mysubdomain.mywesite.ch/blogs/2 but it come back to the home without changes.

    Thanks for your support.
    Pierre-André

    PS: the website is actually not public. I can send you an URL in private if you need it. It's a WP MU with ~150 blogs and ~700 users with a custom template.

  • Mason
    • DEV MAN’s Sidekick

    Hiya!

    It was a problem with an other plugin.

    So often, that's the case. Glad you got it sorted! :smiley:

    When I press "Next", it try to go to http://mysubdomain.mywesite.ch/blogs/2 but it come back to the home without changes.

    Hmm, this sounds to me like an error in your wp-config or (more likely) your database.

    Can you log into your DB and see what you have for "path" in the entry for wp_site? It should be simply a "/" (without quotes of course)

    Also, what do you have as a meta_value for siteurl in wp_sitemeta? It should be "http://example.com"

    Finally, check the options table for the site giving you trouble (wp_SiteID_options) and see what you have there for siteurl. It should be something like "http://subdomain.exaple.com"

    If those are all correct, we'll look at the wp-config settings as well. Thanks! :smiley:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.