/blog info appends to all other pages and posts too before the content that is suppose to show.

Hey folks,

Support access is enabled via the dashboard.

The /blog info appends to all other pages and posts too before the content that is suppose to show.

See screenshots.

That blog content should ONLY be on /blog and not other pages or posts.

If you go to any other page the /blog info is appending to the top of other pages like /register or /privacy-policy etc etc etc. Also, it does it on all posts as well like /blog/the-smart-way etc.

How can that be fixed ASAP?

  • Michael Bissett

    Hey @Greg! :slight_smile:

    In this case, you can just go in and manually edit the pages, I've gone ahead and removed the blog information from the /register page on your site. The social share buttons though had to be removed by inserting this CSS snippet:

    .page-id-132.et_monarch .et_social_inline_top {
        display: none;
    }

    Into:

    Theme Settings -> add custom css rules

    Could you let me know how that looks now please? :slight_smile:

    Kind Regards,
    Michael

  • Greg

    @Michael

    Hmmm...but why does that have to be done per page and post?

    I can not see having to do that for every single page and post on the site now and in the future. That is very very cumbersome.

    I guess this is some kind of bug? Can the developers please rollout a fix asap?

    What are other workarounds to get rid of that on the pages and posts?

    There really should be now reason for this happening. It is very strange and weird.

    Please let me know.

    Thanks.

  • Michael Bissett

    Hey @Greg,

    Hmmm...but why does that have to be done per page and post?

    I can not see having to do that for every single page and post on the site now and in the future. That is very very cumbersome.

    I'm not seeing that it's happening to newly created pages, but I am seeing that the content inside the page is being duplicated when I create it (see screenshot below).

    I'm not able to replicate this over on my own test site presently, it's possible that there might be a conflict on our hands here. Could you try doing a conflict test here, as mentioned at the bottom of our Getting Support page:

    https://premium.wpmudev.org/manuals/getting-support/

    Also, why would the social share need to be removed?

    I would not want to remove the social sharing from every page and post this is happening of course either . . . smile.

    I was only supplying it as an example of the Register page, I didn't mean to specify that the sharing buttons from every page and post. :slight_smile:

    Given the way that the plugin you're using adds this though, I thought I'd suggest it for the Register page, in case there were pages you wanted it hidden for other pages. But if you're wanting to keep it visible, then there's no need to add the CSS code I mentioned. :slight_smile:

    Kind Regards,
    Michael