Blog Page

Site url: http://harmonicspirit.net

In Settings –> General — Reading I have the “static page option selected” Front page is not chosen – I love the default Studio theme page. Under Blog, I’ve chosen my page that I created named Blog. Yet, the “blog” page only shows an image with the name blog.jpg. It doesn’t show my posts.

I would like to have a page with all of my posts showing for my blog. Normally the static front page/choosing blog page works.

Thanks!

  • 3SixtyEvolve
    • New Recruit

    Hi harmonicjupiter

    Welcome to WPMU DEV and thank you for being part of our Community!

    I’ve checked out your website (well done!) and think your page hierarchy might be the issue. Have a look at your pages. I’ve noticed on your blog it says:

    blog – blog

    At first glance I would say you have two blog pages set up, one main and one on sub-level.

    Let me know your findings.

    It would be great to actually see your configuration on your Admin Panel. I also noticed that you don’t have any navigation tabs at the top of your page. I had to scroll to the bottom of the page to find the pages to your site. (Opened in FireFox – latest version). Just thought I would mention it.

    And don’t hesitate to be in touch should you need any further support from our side.

    Have a good day and happy blogging!

    GinaB

  • camparoo
    • Site Builder, Child of Zeus

    Hi there, I have a quick question/comment. I have tried to leave the home page not chosen in the static settings, and have never had that work in the themes I have been using, as the non-static setting makes home the blog page.

    What theme are you using? If it is a wpmudev theme, in the ones I have worked with, you can find a front-page template and a blog template to choose from (in your Dashboard, on your individual page settings).

    If you do have this option, you simply create a home page, leave it blank, make sure you’re using the front-page template for the page, and then do the same for your blog page. Then, you add both pages in your static settings. This works perfectly in the Edu Clean theme as well as Socialize. I am using it here: Menlo Park Legends and it works jolly good.

    Anyway, please pass on the theme you’re using if you’re still having problems with this!

  • 3SixtyEvolve
    • New Recruit

    @camparoo

    Thank you for sharing on the Community Forum! Great to get input from our Members.

    I will definitely bookmark your post for future reference. All these little snippets of advice are a precious source of knowledge for me as I learn more and more about multisites and WordPress.

    Nothing like sharing! Have a great day!

    GinaB

  • harmonicjupiter
    • WPMU DEV Initiate

    I’ve uploaded my settings, my page setup, and the blog page settings in a pdf file here if that helps. I haven’t done anything different from what I’ve done in my other blogs. I’d love to get this fixed as I’m trying to get this site live.

    I’m working on navigation tabs and a better page structure.

    Thanks!

  • 3SixtyEvolve
    • New Recruit

    Hi harmonicjupiter

    Hope you’re well.

    I was going over your PDF and I didn’t find any problem with any of your settings. Then I went exploring on your website and I found a problem with your page hierarchy for the blog posts.

    Your blog posts are not linked to the blog page. See:

    http://harmonicspirit.net/2012/03/06/when-tarot-tells-and-we-dont-listen/ should be:

    http://harmonicspirit.net/blog/2012/03/06/when-tarot-tells-and-we-dont-listen/

    I tested this in my own test environment and couldn’t get my blog articles to post to the blog page either, so I have reported this to the Developer, Tammie, for assistance. Please allow us some time to look at this matter and we will revert back to you with a solution at the earliest.

    And BTW Very good site. You did a great job so far!

    I’ll be in touch shortly.

    Have a good day!

    GinaB

  • harmonicjupiter
    • WPMU DEV Initiate

    Gina,

    Actually, I was waiting because above you mentioned that the developers were looking at the blog…

    “I tested this in my own test environment and couldn’t get my blog articles to post to the blog page either, so I have reported this to the Developer, Tammie, for assistance. Please allow us some time to look at this matter and we will revert back to you with a solution at the earliest. “

    So I’m hoping maybe there’s an update on that? I’ve been looking for a theme update on my blog, but not seeing one yet.

    Thanks!

  • marikamitsos
    • The Crimson Coder

    “So I’m hoping maybe there’s an update on that?”

    @ harmonicjupiter: The answer is given by Tammie, right there under it.

    If you set a static home page you don’t set the blog page just leave that blank. Alternatively you use the blog template page and assign that to a page. It works in both cases for me so if you can try that you should see it working.

    I guess you missed it. Btw I went over to your site and it seems you got it sort out. Great. :slight_smile:

    Please let us know if you need further assistance. We are here to help. :slight_smile:

    Thank you for your time,

    marikamitsos.

    I mark the topic as resolved.

    Thanks again, marikamitsos

  • harmonicjupiter
    • WPMU DEV Initiate

    Actually, I’ve done both of those things and they didn’t work for me… And my site is still the same as it was, with no blog posts showing on the blog page.

    I do not have a static home page.

    I am using “blog news” under the template.

    I will have to scrap hours of work, I’m afraid, as I try to search out a new solution and new theme….

  • harmonicjupiter
    • WPMU DEV Initiate

    I’ve checked out your website (well done!) and think your page hierarchy might be the issue.

    I believe that there is a bug in the page hierarchy for this… I went back in and changed just the permalinks to Default.

    The blog page worked like a charm, but the pages widget still shows all pages as top level pages when a few are sub-pages.

    When I changed the permalinks back to month/day settings that I had, the blog page failed again.

  • 3SixtyEvolve
    • New Recruit

    Hi @harmonicjupiter

    Hope you’re well.

    Thank you for your latest posts. I’m actually interested to see the page hierarchy problem as another user has a similar problem where he can’t get the sub-pages to actually be sub-level. I will try to find more information on possible causes and solutions and revert back to you at the earliest.

    Have a good day and talk soon!

    GinaB

  • harmonicjupiter
    • WPMU DEV Initiate

    Hi Gina!

    I’d emailed you my information, but haven’t heard back. I’m still having the same issue and discovering more glitches… I have to manually set all my blog entries to allow comments since my articles/pages are showing “no comments”.

    Thanks!

  • 3SixtyEvolve
    • New Recruit

    Hi @harmonicjupiter

    I went through my Inbox searching for your email, but didn’t find anything. Please resend and I will look at it first thing in the morning (it’s night time for me here and heading out soon).

    Let me know on this thread what other glitches you’re facing and we can address those as well.

    All the best, have a wonderful day and talk soon!

    Gina

  • harmonicjupiter
    • WPMU DEV Initiate

    Thanks! I’ve resent to gina(a)incsub.com. I hope that’s correct.

    Basically, I think it all stems from page hierachy. I don’t have any issues on other blogs in my multi-site installation, so I wonder if it’s because I started with the network theme, then installed Studio, and now I’m on WPMU-dixi.

    The three issues are

    1) The blog page doesn’t show ANY posts (I no longer use a “blog” page with the Dixi theme)

    2) new posts don’t have comments automatically enabled

    3) the page hierarchy isn’t showing subpages in the page widget (issues with this carried over from Studio).

    Other than minor CSS tweaks, I did not change any code/php.

    Thanks!

  • Timothy
    • Chief Pigeon

    Hey there! :slight_smile:

    Just checking in to see how things are going with this one and if you need any further help. :slight_smile:

    Thread is currently marked as resolved however if you have more questions or need some more help then please feel free to reopen this thread or create a new one and we will be more than happy to offer assistance. :slight_smile:

    Take care.

  • tuxkapono
    • Design Lord, Child of Thor

    It’s unfortunate that this hasn’t been resolved, as harmonicjupiter seems to have chosen a different theme and I’m having the same issue at cspmgroup.com. It will only work if the URL is cspmgroup.com/category/blog, but not cspmgroup.com/blog, which just redirects to the home page.

    In Settings > Reading:

    Static page is selected.

    Front page: “- Select -” , as in nothing selected (that’s the only way it will work)

    Posts page: “Blog”

  • Timothy
    • Chief Pigeon

    Hey there.

    Apologies for the delay in response, but the thread is about 5 months old now, when posting on the back of old threads it can get missed.

    With that in mind its best to always create a new thread with the issue, if needed then link back to the other if it’s relevant.

    As this seems a persistant issue I will ping the developer on this thread.

    Thanks.

  • tuxkapono
    • Design Lord, Child of Thor

    Solution! https://premium.wpmudev.org/forums/topic/i-cant-get-domaincomblog-to-come-up-as-the-blog

    craiggrella – August 9, 2012

    I understand completely, you’ve got one picture in the slider, with an overlay text – set in the theme options panel.

    You’ve got your subtitle text tagline with the 3 info blocks, again all set in theme options panel.

    You want your complete blog to show up when you got to the URL: CSPMgroup.com/blog, but that’s not what happens – it takes you back to your home page instead.

    My guess is there is a bug in the theme. Without actually digging into the code to find out for sure, try this:

    Create a page called “Dummy” – its innocuous enough not to trip any WP functionality. In that page, set the template as blog news.

    Add that dummy page to menu navigation, but once it’s in the menu, rename the navigation label “Blog.”

    That works for me running the same theme in a test site. And I think what Kimberly is saying above is that it works under her test conditions too.

    If this doesn’t work on your end, I’d say there is something else tripping on the word blog or the code is not right, in which case reinstalling the theme would be the first thing I would try.

    If that doesn’t fix it, let me know, and I’ll try to dig into the code to see what, if anything, might be causing this.

    Craig

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.