Blog user admin acces on multisite

Hello! When I create a new site and I try to connect with the new user I get the message: "You do not have permission to access this page." The site structure is like http://site.com/newblog/wp-admin/

  • Adam Czajczyk

    Hello @contact610,

    I hope you're well today and thank you for your question!

    Although I do understand what the issue is here, I'm not quite sure if I'm following you on when it appears. Could you please elaborate a bit on this? It would be great if you could provide me with a simple "step-by-step" description on what exactly should I do in order to try to replicate the issue on my test setup.

    Could you please also grant me a support access to your site so I could take a closer look at its configuration? You may do this via our WPMU DEV Dashboard plugin as described here:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Nicolas

    Hello Adam,

    To replicate the issue, you just have to create a new blog with form on the frontend
    1. Fill user name and email,
    2.Then site name and template (I use pro site and new blog templates plugins).
    3. Confirm by email
    4. Then connect to the admin ...

    Other infos :
    - I am testing many thing on this site, so I have created and deleted testing accounts many times. But each time, deleted new sites, users and cleared wp_signup table.
    - I also installed itheme secutity plugin at the begining and it changed the db prefix
    - The site is currently in maintenance mode

  • Adam Czajczyk

    Hello Nicholas!

    Thanks for you replay.

    I've accessed your site's dashboard again. After disabling "coming soon" mode for a minute (it's back on of course) I opened your site in another browser as a visitor and then followed the steps you described.

    I received activation e-mail, clicked on activation link, then received second mail with password. I easily logged in into my new site's admin dashboard and was able to see and use both the dashboard and a site. (The site and account is still there but you may remove them anytime).

    I wasn't however able to access main site's dashboard and this is perfectly fine as a sub-site admin shouldn't have access to any other dashboard than his own.

    Bottom line is:

    - I was able to use /mynewsite/wp-admin
    - I wasn't able to use /wp-admin (main site)

    Is that an expected behavior on your site or am I missing something here? Let me know please!

    Best regards,
    Adam

  • Nicolas

    Hi Adam, thank you for your help.

    Indeed it seem to work properly but with your help I have pinpointed the origin of the bug. I think it may imply New blog Templates plugin.
    In fact, If the user do not choose a template, the site is normally created with the default template and the administration is accessible. However if you choose a template, the user has no rights to access to the admin page!

    Other infos:
    - You should know that I have changed the site structure from sub-domain to subfolders. Maybe that is the origin of the problem although I changed all the links in the database.

    It appears I have another problem while creating a site. Depending on the browser that is used, the choice of the template is not taken into account. (the new site use the default template)
    From my tests it works with Chrome, Safari and Opera but not with Firefox! I guess the problem is rather CSS or it is a bug with dashlane password manager ... https://premium.wpmudev.org/forums/topic/problem-with-new-blog-templates-plugin-after-switching-to-folder-structure#post-1003225

    Best regards,
    Nicolas

  • Predrag Dubajic

    Hi Nicolas,

    I did some tests on my installation with Pro Sites and New Blog Templates but I was unable to replicate the issues you are having, I was able to create site regardless if I select the template or not, also there were no issues with selecting template while using Firefox.

    Have you tried disabling other plugins and switching main site to default WP theme to see if it works in that case?

    Best regards,
    Predrag

  • Nicolas

    Hello,

    I have tried default WP theme and plugins disabled, I still can't login. This time I do not have the message "You do not have sufficient privileges to access this page", it just reload the login page.
    However I have not encountered the problem with Firefox: It take into account the template choice.

    I also see that I have a problem with the extension Advanced custom fields Pro. This extension requires an update of the database. When I launch the update I still get the message: "You do not have permission to access this page"
    I do not see where these problems come from...I think there was a problem with the migration of the site from sub-domains to subfolders...
    In your opinion is it better to reinstall the site?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.