Blogs directory search not working

We installed blogs directory this morning and it is listing the blogs as it should. However whenever we attempt to use the search field it redirects to a page not found.

Any idea what may be cause this? A step that we missed maybe. Also it seems odd to me that the search form submits to /blogs/search. A page that doesn't exist. However even if I create a search page the search field just returns 0 response and redirects to that newly create search page.

needless to say the documentations doesn't say creating a search page is necessary. A quick response on this would be appreciated.

  • Philip John
    • DEV MAN’s Apprentice

    Hiya,

    I've just tested this out myself on a fresh install and it's a quick fix.

    All you need to do is update your permalinks (Settings > Permalinks) and the new search page should work fine.

    Let me know if it doesn't and we can troubleshoot.

    Cheers,
    Phil

  • jonathandsimmons
    • WPMU DEV Initiate

    What exactly do you mean by update permalinks? Just go and save the current setting? Does it need to be something specific?

    Also it seems odd to us that the search form is sending to /blogs/search/ and since a page called search doesn't exist we get a 404. The documentation doesn't say anything about creating a search page though.

  • Philip John
    • DEV MAN’s Apprentice

    Just go and save the current setting?

    Sorry, yes - that's exactly what I mean. It acts as a sort of refresh for WordPress to go round and check that it has all the right URLs for everything.

    Also it seems odd to us that the search form is sending to /blogs/search/

    Not odd at all :slight_smile: Basically, the plugin uses a nifty feature in WordPress which allows 'pages' to be created that don't exist. So, it creates /blogs and /blogs/search and WP just knows to pass that to the plugin for processing.

    Hope that helps with your understanding!

    Phil

  • jonathandsimmons
    • WPMU DEV Initiate

    Ok, to further clarify when I installed blogs directory a new page was created with the name /blogs. This page had the correct listing of blogs as advertised along with a search form.

    A page for blogs/search/ was not created. Your previous reference lead me to believe it should have been. However your saying it should be created on install. Because it is not being created when I attempt to use the search form the result is a 404 because blogs/search does not exist.

    I even tried to manually creat a search page an made it a child of blogs. Therefore creating the missing blogs/search/. The result is that now when I use the search field I am simple redirected to the empty page search page instead of a 404.

    I attempted to install blog directory on another mu site running the twentyten theme and again got the same broken search and no search page being created.

    Essentially the plugin is full operation except for search regardless of where I've installed it or what modifications I make.

    And yes I have updated my per slinks after each install. Thank has not solved the problem for me.

    Any advice and where to go from here. I'd really like to get the search function working.

  • Philip John
    • DEV MAN’s Apprentice

    Hi,

    Yes, the plugin does automatically create a "Blogs" page. You can see that in the Pages area of your dashboard.

    It doesn't need to create a /blogs/search page because everything goes through the /blogs page. It does this using permalinks.

    If you have manually created a /blogs/search page you should delete it as it will interfere with the operation of the plugin. Then update permalinks again.

    You should only have a /blogs page.

    Phil

  • jonathandsimmons
    • WPMU DEV Initiate

    Phil,
    I'll appreciate your efforts to help. However I will say I don't appreciate a post of mine being marked resolved without a confirmation from me.

    As of this morning the feature was still broken. I spent an hour uninstalling reinstalling and testing this plug-in as I really wanted it to work. After some time I turned off a few other WPMU plugins I had previously installed. (post indexer & global search) both WPMU plug-ins mind you. Then re-installed the blogs directory plug-in. It didn't create the blog page mind you so I created it. Then suddenly everything worked. Without a permalinks update or any other changes.

    Apparently it didn't like something post indexer or global search had installed. I've since reactivated and all three plug-ins appear to be working together without any issues.

    The issue is now resolved.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.