blogs directory showing empty pages

I have blogs directory installed in multisite. I have several blogs blocking search engines which I don't want to be shown in the directory list. The directory plugin shows empty pages or only a few sites where the blocked sites are. It's like it is counting the hidden sites and not showing them. How can I solve this issue?

  • MdW

    Joe,

    You are using the Blogs Directory plugin to display a directory of your blogs and some of the blogs in your network are protected by the Privacy Plugin.

    Some of my blogs are configured to block search engines, they are not using one of the 4 extra options of the Privacy Plugin. The Privacy Plugin provides has 4 extra options, but as far as I can tell these are not configured to block search engines. The sites configures with one of these extra options continued to be shown in blog directory plugin consequently. I cannot tell if this is the intende way for the Privacy Plugin to work or not because I cannot find any documentation on this.

    In turn the Blogs Directory plugin is still displaying those blogs chosen as not to be spidered by the search engines as blanks?

    The Blogs Directory is not showing the blogs chosen as not to be spidered by search engines, but is skipping the entries. Lets say for example:
    - I have 9 blogs configured as follows: 1 open, 2 open, 3 blocked, 4 blocked, 5 open, 6 blocked, 7 blocked, 8 blocked, 9 blocked (newest as lates)
    - Blog Directory plugin configured to show 3 blogs per page showing newest blogs first

    The plugin will show 3 pages as follows:
    page 1 showing empty page (no blogs shown)
    page 2 showing blog 5 (only one blog shown)
    page 3 showing blog 1 and blog 2 (only two blogs shown)

    Hope this description is clear enough.

    Mark.

  • aecnu

    Greetings Mark,

    Thank you for the additional clarification, I think I now have a picture of what is going on here.

    May we please have the URL to this anomaly in which I will present the URL and your extensive last post to the lead developer of Blog Directory plugin to see about what his thoughts are as to why the blocked sites are being acknowledged by the plugin at all presenting them as a blank.

    Please advise so we can see this first hand and have enough info to get the developer involved.

    Cheers, Joe

  • aecnu

    Greetings Mark,

    Just checking if this issue was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thank you for being a WPMU Dev member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.