[BLOGS MU] Bad surprise with gallery path

Hello !

Well bad surprise today configuring sevices options with Blogs MU.

But my config is a little special, certainly a little code coul handdle this :

1 - All themes are in /home/mainsite/public_html/wp-content/themes
2 - All install have a symlink on the theme folder. Till now everythings works fine.

Here is the error :

Warning: mkdir() [function.mkdir]: Permission denied in /home/mgr/public_html/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 335

Warning: chmod() [function.chmod]: No such file or directory in /home/mgr/public_html/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 336

Warning: mkdir() [function.mkdir]: No such file or directory in /home/mgr/public_html/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 341

Warning: chmod() [function.chmod]: No such file or directory in /home/mgr/public_html/wp-content/themes/blogs-mu/_inc/functions/services-functions.php on line 342

I dont understand in fact where he wants to go.
There is the /uploads/ folder, 777 on both installs of course. </p>
How could i handlle that, since i really want to keep my central folder (I am installing more that 10 networks !)
Thanks !

`The incriminated lines are :

if(!is_dir($upload_path_blogid)){
mkdir($upload_path_blogid, 0777);
chmod($upload_path_blogid, 0777);

and

if(!is_dir($upload_path_check)){
mkdir($upload_path_check, 0777);
chmod($upload_path_check, 0777);
}