Blogs MU Upgrade from 1.0 to 1.2.1 - Simple How to Question?

Ok I really tried to find an answer in the support forums here, but the search function is not really good IMHO, I assume all is arranged by tags only?

Anyhow....

Can someone please point me to a post where it was explained how to manually uprade from an older theme to a newer theme? Also I'd be interested in knowing how it's being done for Plug-ins so I don't come back asking in the future

Right now I am trying to upgrade from version 1.0 to version 1.2.1 of blogs MU theme..

I am running a WP Multisite install..

Thanks for taking the time to answer...

Cheers!