blogs.dir issue while installing bullet proof security plugin

While creating a new multisite network blogs.dir folder was not created.

So while installing bulletproof security pro plugin I got this error.

An htaccess file was NOT found in your blogs.dir uploads folder.
The /blogs.dir/.htaccess file is created automatically unless your Server type requires that you create this file manually. If you need to create the blogs.dir Uploads Folder BulletProof Mode manually you can do this on the Security Modes page.

So I created blogs.dir folder inside /wp-content

Now the plugin setting shows like this under “Activate Uploads Anti-Exploit Guard htaccess Security Mode”

http://caricrafts.com/wp-content/uploads/.htaccess –&– /UPLOADBLOGSDIR

It should normally show like this-
http: //xxxx.com/wp-content/uploads/.htaccess –&– /wp-content/blogs.dir

I dont understand why it shows UPLOADBLOGSDIR instead of /wp-content/blogs.dir

  • aristath

    Hello there Jason, I hope you're well today!

    Please try the following:
    - Deactivate the bullet-proof security plugin
    - Delete the plugin from wp-admin/network/plugins.php so that its settings are also deleted
    - Make sure that your blogs.dir folder is writable by your webserver so that an htaccess file can be created if it doesn't already exist there
    - If an htaccess file exists in the blogs.dir folder, make sure it's writable by your webserver so that when you reinstall the plugin it will be able to make the changes it needs to do on that file
    - Reinstall the bullet-proof security plugin, activate it and configure it.

    Let me know how that works out for you...

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.