BlogsMU login and avatars

Two (unrelated I think) questions:
1. I have set MySite -> Appearance -> Theme options : Extra settings - Enable or Disable login panel on top : Enable. But the link does not go to wp-login.php rather there's a comment "http://esp-test.fn.org/you-need-to-create-login-page-in-page/"
screenshot. I've looked at all the theme options and tried creating a Page called 'Login' (it didn't do the job). Any ideas?

2. When I set up a test site with BP/WP and a fresh empty database the default avatar images are displayed. But when I import the database and wp-content from my production site in order to test new plugins the default avatar images are broken (see screenshot above). Could you give me some idea of what is not happening so that I can poke around in the database to fix?

Thanks
Mark