Blue host wildcard SSL

My host is bluehost and I am using dedicated wordpress hosting. They just installed wildcard SSL for one of my site. But my site is not showing https://

In order to force the ssl, I used the following plugins
3. Domain mapping

nothing forced all my site to SSL perfectly, some pages still was on http://

Is there anything I am missing here? Do I have to do anything with htaccess or wp-config?

I have all my subdomains directed to the same wordpress folder, is the following code correct for .htaccess?

# Custom subdomain .htaccess SSL + WordPress
RewriteEngine On
RewriteCond %{HTTP_HOST} ^$
RewriteCond %{REQUEST_URI} !^/subfolder/
RewriteRule ^(.*)$ /subfolder/$1
RewriteCond %{HTTP_HOST} ^$
RewriteRule ^(/)?$ subfolder/index.php [L]
# End custom subdomain .htaccess

# Custom maindomain .htaccess WordPress
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^(www.)?$
RewriteRule ^index\.php$ - [L]
RewriteCond %{HTTP_HOST} ^(www.)?$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# End custom maindomain .htaccess


  • Rupok

    Hi Raj,

    Is there anything I am missing here? Do I have to do anything with htaccess or wp-config?

    You said you are using force SSL plugins and Domain Mapping, but it's almost impossible to say if you are missing any configuration with these installed plugin information and without seeing the full setup.

    However, to initiate the troubleshooting process, can you please check this blog article to know how you can use one wildcard SSL certificate for your entire network?
    This article describes step by step process with screenshots. Can you please check those one by one and try to find out if you missed anything? I believe, after checking the whole article, you will be able to use SSL for all your sites and pages.

    I've got another article for you regarding the same topic: Please have a look at this too. This also describes the process in details.

    If you go to "Dashboard > My Sites > Network Admin > Dashboard > Settings > Network Setup" section, there you will find the optimum ".htaccess" content. That box says:

    Add the following to your .htaccess file in /home/admin/web/, replacing other WordPress rules:

    Please check the attached screenshot for reference.

    For your convenience, I'm adding that code from my SSL enabled multisite, here:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    Please let us know if you have any confusion. We will be glad to assist further.

    Have a nice day. Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.