Booking multiple services in one appointment

The website I have this plug-in installed on is mainly for a sugaring hair removal service, and the clients scheduling appointments will sometimes want to schedule several services in one appointment. SEE WEBSITE

Is it possible to schedule multiple services per appointment, or will they have to continue booking each service separate? I thought I saw something in support documents about a setting in the Add-ons, but didn't see anything in there that looked like the right option.

Any help on this would be greatly appreciated, thanks!

  • Tyler Postle

    Hey Heather,

    There is a way to book more than one appointment at a time. You were on the right track, you need to activate the "Appointments in Product Cart" Add-on. It does require MarketPress though:

    This lets you add Appointments as products to your cart. Everything on your appointment page will be the same except that instead of just confirming the appointment, you will add it to your cart.

    You can add as many appointments as you want to your cart then checkout with all of them at once!

    Hope that solves your issue!


  • Heather

    I installed MarketPress, I activated "Appointments in Product Cart" and now I'm thoroughly confused.

    Everything I had set up on Appointments+ was working great, I just wanted to be able to have multiple services book as one transaction, so it would block of the set amount of time and the client would receive one email for the entire session of multiple services (instead of an email for every single separate service & time slot booked).

    Now I'm confused, how do I get this set up? I read through the MarketPress documentation, but it's structured for setting up a site with products, I don't see anything about making it work for appointments? I don't take payment at the time of the service being booked, and I don't ship anywhere.

    Do I need to add each individual service to products, and then update all of my confirmation emails on the MarketPress app?

    I'm sorry if this should have been a more simple set-up than I'm making it, any guidance would be helpful!


  • Tyler Postle

    Hey Heather,

    I have attached some screenshots to illustrate some of the steps below.

    There are likely a lot of features you won't use in MarketPress since you are just selling appointments. Here are some steps that I think will help you out.

    1. First thing to do is create your product appointment page. Do this by going to Appointments+ > Settings > General Tab > Create an Appointment Product Page (see screenshot)

    2. Set Payment gateway in Products > Store Settings > Payment Settings and select "Manual Payments" This will allow your clients to checkout without having to pay any money and you can collect it later.

    3. Set shipping in Products > Store Settings > Shipping and select shipping method as "no shipping" - This way your clients won't have to enter their address at checkout. Unless you want them too.

    4. You will notice on your new appointments product page now that you can "Add to Cart" after confirming it. You can do this with as many appointments as you want and checkout with 5 in your cart if you like.

    5. During checkout, as shown in the screenshot below, the "checkout" tab has the payment information on it. Since you selected manual payments you will want to customize this page and explain that you collect payment after or however you want to say it. You can customize this page at Products > Store Settings > Payments > Below the gateway list.

    Hopefully that helps clear it up a bit for you! MarketPress is a very feature filled plugin so sometimes tough to find the settings you need.


  • Heather

    I'm stuck at step one...I don't have any option that looks like that. I uploaded and activated MarketPress, I can see the products option on the left hand side of my screen. I also checked the "Appointment in Product Cart" option in Appointment+ settings.

    My appointment+ general settings tab still looks the exact same as it did before. Suggestions?

    ****NEVRMIND, I found that answer, had to turn on payment in appointment+ to integrate with MarketPress*****

  • Heather

    Sorry to keep asking for more help on this, but I'm still having trouble getting this set up.

    @TyePo, I followed your directions, and I was able to create a page where I can add appointments to my cart. When I click check out it takes me to That page has a sidebar and is formatted to match my theme, but other than that, it's blank.

    The appointments go through when I click checkout, they get added to the pending appointments section on Appointments+ but I can't figure out how to give a confirmation message on that page that I end up on after selecting check-out.

    I tried editing that page under the products > store settings > messages and then editing the shopping cart page, and nothing I put there will show up on the page. Is there something I'm doing wrong? Should I be trying to edit another page?

    Again, all suggestions are greatly appreciated, thanks in advance for helping me sort this out!

  • Tyler Postle

    Hey Heather,

    No problem! Happy to help.

    Okay, so are you looking to add content to the shopping cart page or the order complete page? What sort of confirmation message are you looking to add.

    You were in the right spot, Store Settings > Messages. The 3rd text box "Shopping Cart Page" should be the first page you end up on after clicking "Checkout" in your sidebar cart.

    If you want custom content on the final page, the order completed page, then add text to the very last text box on the page. It is labelled "Order Complete Page".

    If you are wanted to edit the text in the manual payments area of the payment page then you have to navigate to Store Settings > Payment tab > scroll down past the gateway list.

    Hopefully one of those is the one you were looking for. I may have misunderstood the problem though; so, if that's the case post back with some more details and I'll get back to you ASAP!


  • Tyler Postle

    My mistake! Okay, I wasn't able to recreate the issue which makes troubleshooting a bit tough. Have you tried switching to the twentytwelve theme temporarily?

    If it works with a different theme then you should check out this post:

    @Paul posts a solution about 19 posts down. Hope that will work for you!

    If it isn't a theme issue then you could also try deactivating all your other plugins and see if it's a plugin conflict.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.