Bottom Corner Chat Box Only Appears in Admin

When I was using the free version of the chat plugin, the bottom corner chat appeared everywhere, whether I wanted it to or not. Now that I have the pro version it will only appear in the admin area of my site, even though I have enabled it to appear everywhere -- no URLs have been entered under the "Hide on URLs" setting. How do I get it to start showing up for logged in users throughout the site?

I've included an image of the main settings in case I've got something set wrong.

  • Lorie

    The old chat plugin was either deleted or overwritten when the new one was installed initially, but I deleted the new one and reinstalled it. I removed my cookies for this site and cleared my cache. I did my best to follow your instructions -- though I should probably also mention that I'm not the only one for whom the chat box doesn't appear. It looks great in the admin area, but hopefully there won't be too many users who can get behind the scenes on my site.

    Since this is a multisite installation, does it need to be network activated to work on the main site? Currently I only have it activated on the one.

    UPDATE: I just activated the plug in on my staging site on the same domain -- it appears on the front page just fine there. The only obvious difference is that I haven't changed any settings yet. I'll try to return the settings on the main site to their defaults and see if I can get it to work again.

    UPDATE: Reset everything on the main site to match settings on the staging site and still it doesn't appear on the front end of the site. Could the fact that BuddyPress is running on the main site be the inhibiting factor?

  • Lorie

    I actually just removed the plugin this afternoon in hopes that after a couple of days it could reinstalled and start acting normally again. Let me get it back in place, then yes, I'd love to have some help figuring out what's up with it. Provided, of course, that it's still misbehaving.

    Ok, the plugin is activated and it doesn't look like any of the settings were lost in the hour or so that it was gone -- and it still isn't showing up on the front page.

  • Michael Bissett

    Hey @Lorie, thanks for re-enabling Support Access here! :slight_smile:

    I do see what you mean by the front end chat not showing up in the lower right corner, though I do note that the chat widget (both the one placed on your home page, as well as the one inside the sidebar on other pages) is being displayed... hmm.

    I'm not able to replicate this over on my own test site (with both BuddyPress & Chat enabled on the main site, and the Twenty Fifteen theme in use), it's showing up in the lower right corner for me.

    It's possible that there's something conflicting with Chat on your site, perhaps another plugin, or even the theme itself. Could I ask you to have a go at our basic troubleshooting flowchart (found at the bottom of our Getting Support page), so we can see about narrowing down the culprit?

    https://premium.wpmudev.org/manuals/getting-support/

    There's also a method mentioned there for disabling plugins via FTP there, so that you can do a "soft" deactivation of them.

    Please advise,
    Michael

  • Lorie

    The chat used to appear on the front page -- back when I just had the free version. The only plugins I've added since then were from all y'all and the theme remains the same, so it would seem unlikely that there's a conflict. I also had the plugin working just fine on my sandbox site on the same network with the same theme. There may be a few plugins that I didn't activate on that site, though. I'll go through and compare the two and see if maybe something there might be making the difference.

    UPDATE: That doesn't appear to have helped. I reduced the active plugins on the main site to match those active on the staging site and it didn't bring up the chat box. And then realized it wasn't set to show up on the front... but fixing that didn't help either.

    UPDATE: Deactivated all plugins except the chat and still have the problem. Remembered that the staging site is using a child theme and the main site is using the parent theme, so switched the main site to the child theme. Still no bottom corner chat on the front page.

    UPDATE: Activated Twenty Fifteen theme, no chat box in the corner. Returning now to my original set up.

  • Michael Bissett

    Hey @Lorie, my apologies for the delay here! :slight_frown:

    This is definitely an odd case, I'd like to have a deeper look at what's going on, and see if there's something under the surface here that's causing a hiccup. Could you please send in the following via our secure contact form:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    On the contact form (linked to below), please select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Michael Bissett

    Hey @Lorie, thanks for sending in those details! :slight_smile:

    After digging into this more, it turns out that inside of:

    Chat -> Settings Common -> Blocked URLs

    The "Load JS/CSS on ALL URLs" setting was set to "No, Only URLs where needed for shortcode, widgets, etc." (it was set to "Yes, All URLs" on your sandbox site, which is why the chat box showed up there.

    I'm now seeing the chat box on the front end, could you please confirm the same on your end? :slight_smile:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.