BP install error message

Hi - any suggestions on how I can fix this?
Thanks

Fatal error: Cannot redeclare bp_dtheme_ajax_querystring() (previously declared in /home/fabufems/public_html/wp-content/themes/blogs-mu/_inc/ajax.php:17) in /home/fabufems/public_html/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php on line 157

  • aecnu

    Greetings jeepgirl,

    Thank you for this great question and a significant item to bring up though you did not give enough information to figure out what is going on there.

    Please advise with a few more details:

    WordPress 3.4.1?
    MultiSite or Solo
    Buddy Press 1.6.1?

    It appears that you went from the Buddy Press default theme straight to the Blogs MU theme and got the ajax error above.

    Any chance you tried going to the Twenty Eleven theme first and then to Blogs MU?

    Please advise.

    Cheers, Joe

  • jeepgirl

    WordPress 3.4.1? = Yes
    MultiSite or Solo = Solo
    Buddy Press 1.6.1? = Yes

    It appears that you went from the Buddy Press default theme straight to the Blogs MU theme and got the ajax error above. Any chance you tried going to the Twenty Eleven theme first and then to Blogs MU?

    Actually I installed Blogs MU first then Buddy Press. I received the error message when I tried to install buddypress template pack plugin.

    Can I just comment out some code somewhere...
    Here is the error message: http://www.fabulousfemales.com/

    Thanks for getting back to me so quickly! :slight_smile:

  • aecnu

    Greetings jeepgirl,

    Thank you for the URL, I did not realize that your site was malfunctioning and that you had not recovered it and supplying the URL made it happen.

    If this were happening to me I would immediately FTP in and delete either the Blogs MU theme or the BP theme pack that you mentioned started this whole fiasco in the first place.

    Please advise if you are able to get the site under control again using my suggestion above.

    Cheers, Joe

  • jeepgirl

    Hi Joe,
    The site has not been launched yet so no worries there.
    Yes, I deleted the BP template pack via FTP but without it I wasn't able to configure the BP pages, so I reinstalled it.

    Let me ask you this:
    Is there a particular order in which these should be installed?
    For example, I installed in this order:
    1) wordpress
    2) Blogs MU theme
    3) Buddy press plugin
    4) BuddyPress Template pack

    Should I have tackled this in a different order?
    Thank you for you advice -

  • aecnu

    Greetings jeepgirl,

    Thank you for the additional question, it is appreciated.

    I would have installed them in a little different order like so:

    1) wordpress
    2) Buddy press plugin
    3) Blogs MU theme

    I would have skipped the below package because the Blogs MU theme already has the functionality built in and therefore caused the conflict (see below)

    4) BuddyPress Template pack

    The Buddy Press Template Pack is outdated for WordPress and BuddyPress, a few versions for WordPress and more versions for Buddy Press.

    Taken right from the Buddy Press Template page, it says it Add support for BuddyPress to your existing WordPress theme but the Blogs MU is not a WordPress theme so to speak, it is indeed Buddy Press capable therefore causing the conflict we were experiencing between the two.

    I would recommend dropping the template pack (not activating it) if you are indeed working with a Buddy Press aware theme already. In addition, the package is indeed outdated.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.