BP Social and BuddyPress Upgrade

Hello,

I recently tried to upgrade to BuddyPress 1.5, using BuddyPress, BP Social Theme (The latest with the 1.5 BP fixes, and several of the plugins on this site. When doing so, I get a series of Deprecated Errors that I can't get rid of.

My site is: http://www.customerserviceinthecloud.com
The errors are a bunch like the following:

Deprecated: Assigning the return value of new by reference is deprecated in /var/www/vhosts/customerserviceinthecloud.com/httpdocs/wp-content/plugins/membership/membershipincludes/classes/class.ping.php on line 461

I already attempted to remove the errors by surprising them using the following code in the WPConfig.PHP file:

// Hide E_DEPRECATED messages.
if (defined('E_DEPRECATED')) {
error_reporting(error_reporting() & ~E_DEPRECATED);
}

Stil no luck. Any assistance would be appreciated.

THanks,