BP Social Theme + Full Width Page Template not working in explorer

Hi Folks,

Need some help to debug what appears to be Template bug with BP Social and Internet Explorer where all the full page template fails to render in IE showing a blank - right column.

(Wordpress 3.1 + BP Version 1.5.5 | - this is a new install)

The full template works in all other browsers including Firefox, Chrome and Safar, I tested in https://browserlab.adobe.com and directly via browsers.

Here is a sample link to a clean new page:

http://www.thetraderstouch.com/online-day-trading-community/full-width-test/

Any thoughts? I have tried to disable all plugins and can not seem to find a conflict that is effecting ie.

Thanks
Erik

  • 3SixtyEvolve

    Hi Erik

    Hope you're well.

    I had a look at the link you provided and found that it isn't displaying correctly in IE9, however in Chrome and FF it displayed perfectly.

    Now problem is, I also went and tested it on my own test install, but I didn't face this problem (please see my screenshot taken from IE9). So there has to be some type of conflict on your end. My configuration - WordPress 3.3.1 and BuddyPress 1.5.5.

    Please make sure that you have the latest version and test it again - let me know if the problem persist.

    Look forward to receive your feedback.

    Have a good day!

    Gina

  • kampester

    Hi Gina

    I appreciated the timely response and screenshots that shows the simplest install of buddypress and the theme works in IE. I did do a retest based on your confirmation that it should work and I found a conflict with the a premium plugin called "smart sliding note".

    http://slidingnotes.forwordpress.net/try-it

    Now it appears to me that there must be a flawed coding issue with the Social Theme, because I found another error in IE with the Drop Menus that go 3-levels deep. The 2nd drop menu (sub-sub menu) disappears and a user can not select the menu item.

    http://www.thetraderstouch.com/

    I attached a screen shot and you can see the issue here on the top menu under:

    "Courses --> Level 1 --> Module 1 --> Chapter 1"

    In this case chapter 1 can not be selected, but the menu works fine in all other Browsers.

    Again, the Social Theme in IE fails ... yet functions in other browsers. Is it possible that there is coding issue with Social Themes?

    The "smart sliding note" plugin functions perfectly, except the Social Theme on the Full-Page Width template seems to break the theme by failing to hide the right column

    Can you please advise? Again I appreciate your efforts

    Warm Regards

    Erik

  • kampester

    Hi Gina

    I have not heard a reply, but hoping that you have eyes on this issue.. I really need your help to valid this, since coding is not a my strength. ...

    I have dug deeper and have found that the problem happens problem at the <div id="post-entry">

    I attached an Layout Model here where it shows that all other browsers show the proper settings except in IE.. where the box model in IE does not show.

    (See attachment)

    I also confirm that SmartSlidingNote pluing is not the source. I missed to test the obvious.. which was the condition where I ran a test with only the SSN, buddypress and IE... the full-width template worked fine,

    So right now I have no clue... I have been able to reproduce the issue with many different combos of plugins... they all produce the problem at post-entry div and there is something about the Social Theme that is not responding to the id=custom tag.

    I do not have the coding skill pin point a splution ... but I hope this helps you narrow down the issue to the the Social Theme code structure.

    Thanks again

    Erik

  • kampester

    Okay - still no response from support?? Whats up guys.... hope I can get help here.

    From all my testing ... everything points to the Social theme as the source... I could be wrong but I would need help from support on this discussion ...

    As I look at the below code snippet the >#custom #post-entry declares a width of 655 and IE is showing that - while the other browser are handling the code differently.

    Hoping to get some help...

    Trying to be patient.... :wink:

    Erik

    <!--[if IE 6]>
    <style type="text/css">
    #custom #top-header {
    background: #bcc7dd none !important;
    }
    div.item-avatar img { width: auto; height: auto; }
    </style>
    <![endif]-->

    <style type="text/css" media="all">#custom #home-left #box-left {
    width: 100% !important; padding: 0px !important; margin: 0px !important;
    }
    </style>
    <style type="text/css" media="all">#custom #post-entry {
    width: 655px;
    padding-right: 15px !important;
    border-right: 1px solid #ddd;
    }
    </style>

    <style type='text/css' media='screen'>body { padding-top: 0px !important;
    </style>

    <style type="text/css" media="all">#custom #member-left { display: none; }
    #custom #content { width: 650px; padding-right: 30px !important; }
    #custom #item-header-avatar, #custom #item-actions { display: inline !important; }
    </style>
    <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
    <![endif]-->

  • kampester

    Thanks for your suggestions. I just used a hack t on the page to make it work.

    For whatever reason IE still breaks on the fullpage template with my selected plugins where other browsers are fine. I still can not understand how BP Social fails to provide a robust solution for compliant engineered plugins.

    Can you please confirm that BP Social theme adheres to WordPress conventions or does not attempt to shortcut or bypass the WordPress API in ways that cause conflict with plugins that do stick to those conventions and API?

    It would be greatly appreciated. Thanks again

    Erik

  • 3SixtyEvolve

    Hi Erik

    Apologies for not being in here for a while. I have been on and off sick during the last week so haven't been able to give you the timely responses that I would have liked to. Also, I hope this won't affect your opinion of our support service in general, but this merely reflects that we are all human. :slight_smile: I try my best and hope to continue providing you with support until we have this sorted.

    You asked some questions in your last post. Allow me to ping the Moha, the Developer to ask him to answer those.

    In the meantime, if you have any further questions or get stuck with something, please don't hesitate to be in touch.

    Have a good day!

    Gina

  • kampester

    I was hoping to hear something - can someone please confrim that the BP Social theme is DEFECTIVE and not cross-browser compatible?

    Please do not get me wrong, I love the the theme look and feel and have been able to work with it through my site development. However, the problem the theme chronically breaks on IE where it does not break on: chrome, firefox and safari....

    So what is up with that unexpected behavior?

    So far here is where IE breaks and does not play nice with so many other plugins.... (remember the plugins all play nice with other browsers).

    1) full-width template
    2) menu (3 tier level items drop down fails)
    3) maxCDN and W3 Cache breaks on all minify settings (HTML Settings)

    The question remains why this theme BP Social chronically breaks on IE but plays nice on ALL other browsers.

    Thanks

    Erik

  • aecnu

    Greetings Erik,

    The question remains why this theme BP Social chronically breaks on IE but plays nice on ALL other browsers.

    To answer your question, since as you have acknowledged plays nice on ALL other browsers, has it not occurred to anyone that it is truly IE that is defective? Or is it that all other browsers are defective and that IE is not?

    As a matter of fact in my personal computer history since 1980, when has it been, just one single incident, that MicroShaft has released a product that is not defective in one way or another?

    I digress since these thoughts will certainly not resolve the issues we are encountering regardless of MicroShafts history of clear incompetency at all levels.

    Which version of IE are you referring to IE8 or IE9?
    Have you updated to WordPress 3.3.2?
    Have you updated the theme to version 1.3.5 that has been released since this ticket was opened?

    Please advise.

    I truly want to help get this resolved as you do and I appreciate your working with us to cure any and all issues you may be having with this theme or any WPMU Dev products that you have issues with.

    Sincerely, Joe

  • kampester

    Hi Joe...

    Tested in IE 9 and 6 via adobe labs tools, as I stated in my original question.
    ...
    "The full template works in all other browsers including Firefox, Chrome and Safar, I tested in https://browserlab.adobe.com and directly via browsers."

    I appreciate the reach out, however I moved on and hacked my install to make it work. The recent update to the social theme and other configuration options used allowed me to find a move forward solution.

    I consider this ticket closed - IE is

    Thanks again

    Erik

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.