BP- Social theme the tabs are blank after activation

Hi
We have used the BP- Social theme the tabs are blank after activation. We are unable to use any functionality as all tabs are blank despite using child theme.
Regards,
Raghu

  • Elliott Bristow
    • The Bug Hunter

    Hi @shankara.sastry,

    Welcome to the forums!

    I just had a quick look at your site and notice that you have made some tweak to the theme (my! that's quite a bright green you have there!). I also notice that there are no tabs showing (they're not blank, they're just not there).

    Can you add some pages or a custom menu to add some tabs so that we can take a look at exactly how they are displaying when they are there, then we can see if there is a CSS tweak needed to make them display correctly.

  • Elliott Bristow
    • The Bug Hunter

    Ah you don't mean blank... you mean empty!

    How are these pages added to the menu? Are these the default pages created by the plugin or have you created new pages and added them to the menu?

    Other than that, I can see a lot of javascript errors on your site, which suggests a faulty plugin or an error in some tweak you have made to the theme. jQuery is failing to load, which is unusual, and would cause numerous problems with your site.

    To try and trouble shoot this, my suggestion would be to disable all plugins on the site except BuddyPress... see if that fixes things. If it does, slowly start re-activating plugins until you find which one breaks the site.

    If deactivating everything except BuddyPress DOESN'T make the problem go away, try switching to a different theme, such as Twenty Twelve and see if that fixes it.

    Try that, let us know how it goes and we'll make some more suggestions if you still need help.

  • Elliott Bristow
    • The Bug Hunter

    The theme doesn't create any pages, it simply displays them. BuddyPress would create certain pages, and you would create others via the WordPress Pages menu. Directory does create virtual pages, but these can be overwritten if you create a page or post with the same slug manually in WordPress.

    The page created by Directory is, by default, called "Listings", which is why I don't think the page you are showing is created by our plugin. It seems to me that you have simply created a page in WordPress and added it via a custom menu rather than using the page created by the plugin.

    Have you tried disabling any custom menus and usign the menu generated by WordPress?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.