[Branda] Admin bar module not hiding WP Menu

I have the Admin Bar module enabled and also have it set to hide the WordPress Menu, this was working in past version, however after updating to the latest one, it seems broken, more details on how to reproduce in the ticket details.

  • Bamboo Kit
    • Staff

    Hello scooby

    Hope you’re well today and thank you for reaching out to us.

    I’m sorry for the issues you are facing. I’ve managed to recreate all the same behaviours on my test site, just as you have described.

    In this case I have to create a bug report from your ticket and posted it for our Branda developer team. I also searched for a workaround or maybe a quick fix for this, in order to do that please paste this Custom CSS below to Branda -> Custom CSS this will hide the WordPress logo in backend, however, in front-end please also paste this CSS in Appearance ->Customize -> Additional CSS

    li#wp-admin-bar-wp-logo {
    display: none;
    }

    Branda Custom CSS (for backend CSS)

    Theme Additional CSS (for front-end CSS)

    Thank you for letting us know.

    Kind regards,

    Bamboo

  • EcomEric
    • Site Builder, Child of Zeus

    I appreciate your solution, though I can wait for a fix in the next update.

    I'm not sure if it will be caught or not, so I should point out that the settings menu for the menu bar has an issue in the update as well. See attachments.

    V3.1

    v3.1.1

  • Bamboo Kit
    • Staff

    Hello, scooby

    I hope you’re well today and thank you for the reply.

    I’ve contacted our developer team and it turns out that this is not a bug, however, in order to hide the Admin menu bar in front-end too, you have to select the “Toolbar Visibility” to be Visible as well for this to work in the “front-end”

    Please find this tutorial video below:

    https://www.loom.com/share/47790065b4e448e2b3c4783cfe6f9c56

    Here is a screenshot where you can find “Toolbar Visibility”

    Moreover, about the missing menu items, I believe it’s a cache issue, could you please try to deactivate Branda and re-activate her again, then see if this issue still exists. If it still exists, please let me know and also grant support access by following these steps below.

    1. Log in to the WordPress Admin Panel for your site (go to the Network Admin dashboard if on Multisite), and then navigate to the “Support” page from the WPMU DEV menu item (WPMU DEV -> Support -> Support Access)

    2. Click the “Grant Support Access” button in the Support Access panel.

    For more information about Granting Support Access please read this guideline: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-5

    After you have granted the access, please inform me in this ticket thank you.

    Kind regards,

    Bamboo

  • EcomEric
    • Site Builder, Child of Zeus

    Missing items must have been a cache issue. [Resolved]

    Back to the wordpress menu. I think its crazy that to hide that on the front end if you need to activate the bar to be shown at all times, to all people, the point is to be removing items. The showing of the menu bar to all visitors has nothing to do with the other setting for what I want logged in users to see…

    Please make menu item visibility consistent between the front and back end.

    Thanks

    Eric

  • Bamboo Kit
    • Staff

    Hello, EcomEric

    I hope you’re well today and thank you for the reply.

    Our developer has created a task to fix this issue in the next release version of Branda, we really appreciate your patience on this.

    Sorry for the inconvenience.

    Kind regards,

    Bamboo

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.