[Branda] Branda looks strange

Branda does not display correctly on my site's admin. Just installed/reinstalled. Haven't used it so not sure if it is just the looks in the admin or the function as well. Can you please take a look? I have already granted support access so you can do it.

  • Dimitris
    • Support Star

    Hello there Pat,

    hope you're doing well and thanks for reaching us!

    Branda settings page looks broken indeed. As this isn't happening by default, it seems like a conflict with another plugin or active theme. Could you please proceed with a conflict test to narrow this down?
    First, create a recent backup in case you lose any settings during the test and have to restore to a previous working state.
    Then deactivate all plugins and apart from WPMUEV Dashboard and Branda, activate a default theme like TwentySeventeen, clear all caches and check again if the issue is still there. If not, it means that something is conflicting, so start activating the remaining plugins and theme, one by one this time, checking every time for the reported issue, until you reproduce the issue, thus finding the conflicted combination. The following flowchart image can assist you during this test: https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    If this is a live website with traffic, I'd rather advise to create a staging environment, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, and perform the test in there instead without worrying about the live site. Reference: https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-2

    Looking forward to your results!
    Thank you,
    Dimitris

  • Dimitris
    • Support Star

    Hello there Pat,

    appreciate the feedback on this! :slight_smile:

    Could you please share more access details with us, so I can forward this issue along with the theme files to our Branda developers, so they can have a look in case we can fix this in our end or provide some kind of workaround/hotfix for this. As this is a public forum, you should send us your details through our safe contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question
    using this template:

    Subject: "Attn: Dimitris"

    - WordPress admin (login URL/username/password)
    - (S)FTP credentials for file access (host/username/password/path of the website in question)
    - link back to this thread for reference (e.g. https://premium.wpmudev.org/forums/topic/example-topic)
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.
    Thank you,
    Dimitris

  • Dimitris
    • Support Star

    Hello there Pat,

    hope you're doing well and appreciate the email. :slight_smile:

    I was able to replicate this in a testing site of mine so I've already created a bug report for our developers. As soon as there's any development on this like a hotfix/beta version that could fix this, myself or another colleague of mine will keep you posted here.

    During the conflict test though, I was able to actually get the proper Brand styles by enabling the Classic Editor plugin (https://wordpress.org/plugins/classic-editor/), so I think that you could temporarily activate this plugin, setup Branda settings and then deactivate it.

    Warm regards,
    Dimitris

  • Dimitris
    • Support Star

    Hello there Pat,

    hope you're doing well today! :slight_smile:

    I've got some feedback from our devs and they found what's causing this. It's because of a wrong usage of the admin_body_class filter in Themify Ultra theme. I've already contacted their support to let them know, meanwhile you can either hard-code the theme (I'm sure that they will fix this in a future release) or wait for next Branda version which will surpass that either way (this should be at the beginning of next week, as it's already in QA, but if you still wish the latest beta, please do let me know).

    For editing the theme, go to file:
    wp-content/themes/themify-ultra/themify/themify-builder/classes/class-themify-builder-gutenberg.php
    Line 102

    and replace
    $classes .= 'themify-gutenberg-editor';
    with
    $classes .= ' themify-gutenberg-editor';

    It is missing a space before the "themify-gutenberg-editor" string, which can cause issues, as described here: https://developer.wordpress.org/reference/hooks/admin_body_class/#comment-1012

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.