[Branda] Conflict with Membership causes incorrect lost password link on login screen

I created a custom login screen with Branda. It all works great, except for the "Lost your password?" which is not directing to the correct page.

  • Predrag Dubajic
    • Support

    Hi Shinshuri,

    I had a look at your setup and the issue has nothing to with Branda, it's actually caused by WooCommerce which uses its own lost password page which is defined in WooCommerce > Settings > Advanced panel.

    It's set to go to my-account/lost-password/ And you are using Membership 2 to protect My Account page so when visitors try to go to Lost Password page they will be denied access.

    You can disable protection of My Account page so that the lost-password is available again or you can try overwriting WooCommerce lost password URL with something like this:
    https://premium.wpmudev.org/forums/topic/changing-lost-password-url#post-1294213
    However, I'm not sure how my control over this will WooCommerce give you and you might end up needing a custom code to overwrite Woo settings.

    Best regards,
    Predrag

  • Shinshuri
    • Site Builder, Child of Zeus

    Hi Predrag:
    I really need to protect the My Account page with Membership 2 Pro because it is a members only page with other product features and content specific to members only. It is not a public page. I need to have the default WP forgot/reset password page placed on the link on the login screen.

    How do I deactivate the Woocommerce forgot/reset password settings and have the link point only to the Default WP password page?

    If you look at our Login Page it is the default WP Login page with Branda applied to customize the design. On the Login Page see link https://businessphilanthropist.com/mylogin. The Lost your password? link should be linked to the default WP Forgot/Reset page and not the My Account/lost-password page. I don't know how Woocommerce is overwriting the WP Default page on that link.

    Do you have any recommendations for how to set the Login Page link back to the default WP Lost password page?

    or

    How can I point the link to a different page that is not protected by Membership 2 Pro?

    Thanks,
    Dr. Shinshuri

  • Shinshuri
    • Site Builder, Child of Zeus

    Hi Predrag:

    I figured out how to deactivate the Woocommerce lost-password setting and restore the default WP Lost Password link. In case someone else has this issue, all that needs to be done is remove the lost-password reference text from the Account Endpoints Section. See the steps below:

    1. Go to WooCommerce plugin menu
    2. Click Settings
    3. Click Advanced tab
    4. Scroll down to the Account Endpoints section
    5. Remove any text in the Lost Password text field.
    6. Thant's it. Violá! Like magic the Lost your password? link reverts back to the default WordPress page on the login screen.

    Thanks,
    Dr. Shinshuri

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.