Branda permissions not working for superadmins

We’re finding that superadmin accounts are being locked out of accessing Branda with a simple error message: “Sorry, you are not allowed to access this page”.

This happened after the last update (3.2.1)

  • Adam Czajczyk
    • Support Gorilla

    Hello Creative Blogs

    I hope you’re well today and thank you for getting in touch with us!

    There is an issue with permissions on multisite, unfortunately, and our developers are working on a permanent fix for this (which should be included in 3.3. release). As of now, please try following way (I realize you tried similar solution but please try again, following these steps exactly):

    1) login to the site as super-admin
    2) disable the plugin
    3) clear all caches on site and server (that’s very important)
    4) access the database and remove the entire “ub_permissions_users” option from the “_options” table
    5) delete the plugin
    6) clear all caches again (especially object cache if there is any)
    7) install the newest release of the plugin again, activate it and you should see and have access to it so go to the “Network Admin -> Branda -> Settings -> Permissions” page and make sure that all the allowed users/super-admins are explicitly added to the “Custom Users” section there.

    Let me know if it worked for you that way, please.

    Kind regards,
    Adam

  • Creative Blogs
    • Site Builder, Child of Zeus

    We’ve been going through the steps to try this on Chorleystjames.net but unfortunately we couldn’t find the option ub_permissions_users under the wp_options table.
    We also tried skipping that step in case the option didn’t exist in the first place without any luck.

    Can you please confirm the correct place of where this option can be found and whether we are looking under the correct table?

  • Adam Czajczyk
    • Support Gorilla

    Hello Creative Blogs

    You’re right and you won’t find that option in wp_options if it’s a Multisite install. It’s there on single WP installs but on multisite it’s in wp_sitemeta table.

    That was my mistake and I apologize for misinformation. The suggested steps, with the exception of option location (so it’s in “wp_sitemeta” on Multisite instead of “wp_options” like on single installs), are still the same though.

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.